TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

All right, this is driving me crazy... I have thesis example template with one reference that I'm trying to compile with TeXstudio on Windows 7.

My thesis template looks like this:

...a bunch of text
This is some more text \cite{greenwade93}.

My references are in References.bib:

author  = "George Greenwade",
title   = "The {C}omprehensive {T}ex {A}rchive {N}etwork ({CTAN})",
year    = "1993",
journal = "TUGBoat",
volume  = "14",
number  = "3",
pages   = "342--351"

The bibliography shows up with the reference at the end of my thesis and the .bbl file looks fine. However, the citation in the text is just a bolded question mark.

I do get a warning that:

"Latex Warning: Citation 'greenwade93' on page 4 undefined on input line 810."

This is my thesis.bbl file:


George Greenwade.
\newblock The {C}omprehensive {T}ex {A}rchive {N}etwork ({CTAN}).
\newblock {\em TUGBoat}, 14(3):342--351, 1993.


This is my thesis.blg file:

This is BibTeX, Version 0.99dThe top-level auxiliary file: thesis.aux
The style file: plain.bst
Database file #1: References.bib

The thesis.aux also looks fine to me... The last few lines of the .aux file are:

\@writefile{toc}{\contentsline {chapter}{Bibliography}{6}{subsection.4.3.2}}

I've searched here and through google for this problem and have found lots... But most of the answer seem to be to run Latex > Bibtex > Latex > Latex

But that is what I'm already doing I think, so I'm stumped. Any help is much appreciated!

share|improve this question
If I build with your information snippets a minimal example it works fine. So the problem lies in something you are not telling. So try to make a small but complete example. – Ulrike Fischer Feb 13 '12 at 9:57
You are probably removing the .aux file prior to running LaTeX again. – egreg Feb 25 '12 at 14:23
When I run the minimum example using TeXStudio, I get the same problem, so it is to do with TeXStudio and the way it is configurated... – user12522 Mar 11 '12 at 22:13

I just had the same thing happen to me after installing texstudio on my new pc. I ran it in the command prompt so I could see the errors (must be a way to do this in texstudio, but whatever)...

pdfatex mytexfile  
bibtex mytexfile

turns out I had two problems:

1) my bibstyle hplain.bst wasn't being found (probably not your problem but you could try using "bibliographystyle{c:/blablabla/plain}", where blablabla would be the path to the plain.bst found by typing plain.bst into google.

2) there were some error in the .bib file I referenced in mytexfile.tex

I fixed these two problems and presto! Don't know why my bibtex previously ran back when I used to use the command line version installed on my terminal at work, but either way it works now. I think the thing it was most mad about was my use of % to comment things, which apparently is not appropriate in BibTeX.

Anyways... hopes this helps someone out there. Toodles.

share|improve this answer

I also had this problem. I solved it by setting the path of the bibtex.exe as the following steps:

  1. click the Options menu
  2. click Configuration TeXstudio
  3. click Command and the enter the path of bibtex.exe in your machine, for example its path in my PC is C:/Program Files (x86)/MiKTeX 2.9/miktex/bin/bibtex.exe, you can enter it as follows:

    "C:/Program Files (x86)/MiKTeX 2.9/miktex/bin/bibtex.exe  " %
share|improve this answer

I had a related problem -- my citations were not visible in the main PDF. To fix this I removed the empty spaces in the filename of my .bib and re-referenced it in the main .tex file. This worked.

old filename: "my references.bib" new filename: "myRef.bib"

Of course, changed the main.tex file's \bibliography{myRef} to include the new filename.

Hope this helps.


share|improve this answer

I had a related problem, and a Google search led me to this question ... so I will leave my solution here, in case others run into the same problem. I was using TeXstudio and running BibTeX but no references or citations were showing up. No errors popped up when compiling.

The problem was that I was using


instead of


so TeXstudio was looking for a file references.bib.bib, which of course did not exist.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.