Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Is there any way to suppress the PDF preview appearing? I really don't like the internal PDF viewer and I prefer using Acrobat. (I know that on Windows, Acrobat makes the .pdf file read-only, but I'm on linux and it behaves better here). It is annoying pop-up that I have to kill or so whenever I compile.

share|improve this question
1  
I miss few things: facing pages, anti-aliasing, countinuous page mode. Maybe some new version have it, but I have an old linux distro and miss the new updates. –  tohecz Feb 14 '12 at 0:24

2 Answers 2

up vote 6 down vote accepted

In the "Typesetting" tab of the preferences, you can double click the tool you use, say "pdfLaTeX" and there you can disable "View PDF after running".

I'm afraid you have to do it for all tools.

share|improve this answer
    
Thanks, I use only two of them so it's pretty fine for me! –  tohecz Feb 13 '12 at 14:43

Opening the PDF viewer part of TeXworks is configured on a per-tool basis in the Typesetting preferences. So for example to prevent the viewer opening after typesetting using pdfLaTeX, I would need to untick the box in the following dialog enter image description here

(Screenshot on Windows, but the same principal applies on Linux)

share|improve this answer
    
Thanks for the answer, but it seems that egreg made it 2 minutes faster! :-o –  tohecz Feb 13 '12 at 15:05
2  
@tohecz: This would have been 3 minutes faster without the pretty picture! ;) –  qubyte Feb 13 '12 at 15:31
    
I know, but I didn't want to un-accept the first answer since it was what I really used... J.W. gets more upvotes, so it equalizes them ;) –  tohecz Feb 14 '12 at 0:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.