Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

i couldnt find this on web search, my prof. told me to use a "paragraph" command, with attributes like in the headline description, in certain situations. But all I could find is a command called "paragraph", it lists itself in the table of contents though, which I want to avoid. Which command am I looking for to get what I need.

I use this document class

\documentclass[ngerman,bt]{dbvdoc}

thanks a lot in advance, daniel

share|improve this question
    
It is always best to compose a fully compilable MWE that illustrates the problem including the \documentclass and the appropriate packages so that those trying to help don't have to recreate it. –  tohecz Feb 14 '12 at 9:18
    
ok, I will do it later, I thought maybe some people know the answer without testing it. –  dan Feb 14 '12 at 9:23
    
The problem is that this much depends on the class you use, I posted likely-working answer below. –  tohecz Feb 14 '12 at 9:24
    
If the dbvdoc class is based on KOMA-Script – what we can’t see, because it seems, it is an internal document class (for the German insurance DBV?) – then there is a command \minisec which works as expected. –  Speravir Feb 14 '12 at 19:51
add comment

3 Answers

up vote 4 down vote accepted

Play with both counters of the minimal example, or use paragraph*, or use the description environment if do you want also a hanging indent

\documentclass{article}
\setcounter{secnumdepth}{3}
\setcounter{tocdepth}{3}
\begin{document}
\tableofcontents{}
\section{Section}
\subsection{Subsection}
\subsubsection{Subsubsection}
\paragraph{paragraph } numbered but not listed in TOC.
\paragraph*{Paragraph } not numbered and not listed.
\begin{description}
\item [{description}] environment
\item [{second}] item of descrition
\end{description}
\end{document
\end{document}
share|improve this answer
    
the \paragraph with the asterisk did the trick. Thank you! –  dan Feb 14 '12 at 9:30
add comment

\paragraph is a sectioning command whose numbering and inclusion in the table of contents is governed by the counters secnumdepth and tocdepth.

Specifically (in the standard classes) it is considered at level 4:

chapter = 0 (if existent in the class)
section = 1
subsection = 2
subsubsection = 3
paragraph = 4
subparagraph = 5

Thus any setting such as \setcounter{tocdepth}{<n>} (where <n> is an integer less than 4) will not include sections introduced by \paragraph in the table of contents. The default value of tocdepth is 2.

However, sections introduced with \paragraph* will not be numbered nor included in the table of contents.

I recommend you not using \paragraph* directly, though: write in your preamble something like

\newcommand{\mydivision}[1]{\paragraph*{#1}}

and use \mydivision{Word}. You may so easily change your mind about the rendering of these things. For example, a definition that doesn't abuse the sectioning commands might be

\newcommand{\mydivision}[1]{%
  \par\addvspace{\baselineskip}
  \noindent\textbf{#1}\enspace\ignorespaces}
share|improve this answer
add comment

You should try to include these two lines in your preamble. They modify the depth of table of contents:

\setcounter{tocdepth}{3}
\setcounter{secnumdepth}{3}
share|improve this answer
    
hmm thank you it doesnt work. Im on depth level 2, later I will go deeper. The reason I dont want to have it in the table of contents is because the section is too short. –  dan Feb 14 '12 at 9:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.