Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have this problem. After the last modification, I have the following Biblatex part in my preamble:

\usepackage[style=verbose-    ibid,firstinits=true,sorting=nty,sortcites=true,useprefix=false,isbn=false,maxnames=6,backend=biber]{biblatex} % originally the style was verbose-ibid
%\usepackage[style=footnote-dw,namefont=smallcaps,firstinits=true,idembib=true,idembibformat=dash,nopublisher=false,edbyidem=false,backend=biber]{biblatex}
%%\DeclareFieldFormat{shorttitle}{\mkbibemph{#1}}
%\DeclareFieldFormat[article]{title}{\mkbibquote{#1}}
%\DeclareFieldFormat{journaltitle}{\mkbibemph{#1}}
%\DeclareFieldFormat{editor}{\mkbibnormal{#1}} %take off the uppercase from the editor, it does not work yet
\renewcommand*{\mkbibnamelast}[1]{\textsc{#1}}
\renewcommand*{\newunitpunct}{\addcomma\space}%put commas instead of periods after some elements of the title
%\usepackage{biblatex}%remove �in� in journal articles
\renewbibmacro{in:}{%
\ifentrytype{article}{}{%
\printtext{\bibstring{in}\intitlepunct}}}
\renewcommand*{\labelnamepunct}{\addcomma\space}
\renewcommand*{\nametitledelim}{\addcomma\space}
\renewcommand*{\bibfont}{\small}

\renewbibmacro*{publisher+location+date}{%
\printtext[parens]{% ADDED
\printlist{location}%
\iflistundef{publisher}
  {\setunit*{\addcomma\space}}
  {\setunit*{\addcolon\space}}%
\printlist{publisher}%
\setunit*{\addcomma\space}%
\usebibmacro{date}%
}%\nopunct% ADDED
\newunit}
%for citing short forms
\renewbibmacro*{cite:short}{%
\printnames{labelname}%
\setunit*{\nametitledelim}%
% If article:
\ifentrytype{article}{%
    \usebibmacro{journal}%
    \setunit{\addspace}%
    \printfield{volume}}{%
% If incollection:
\ifentrytype{incollection}{%
    \usebibmacro{in:}%
    \printtext[booktitle]{\printfield[titlecase]{booktitle}}}{%
% Else:
\printtext[bibhyperlink]{\printfield[citetitle]{labeltitle}}}}}

%for defining shorthands
\defbibcheck{noshorthand}{%
\iffieldundef{shorthand}{}{\skipentry}%
}

\DeclareFieldFormat{postnote}{\mkcomprange[{\mkpageprefix[pagination]}]{#1}}
\DeclareFieldFormat{pages}{\mkcomprange{#1}}

\setcounter{mincomprange}{100}
\setcounter{maxcomprange}{100000}
\setcounter{mincompwidth}{10}

\makeatletter
\patchcmd{\blx@comprange@check}
{\blx@comprange@comp{#1}{#2}}
{\blx@tempcnta=#1
\divide\blx@tempcnta100
\multiply\blx@tempcnta100
\ifnumequal{\blx@tempcnta}{#1}
 {\blx@range@out@value{#1\bibrangedash#2}}
 {\blx@comprange@comp{#1}{#2}}}
{}{}
\makeatother

\DeclareFieldFormat{postnote}{#1}% no postnote prefix in "normal" citation commands
\DeclareFieldFormat{multipostnote}{#1}% no postnote prefix in "multicite" commands

I do not include the bibliographic entry, as it would be the usual in any case. I have not found the information, but I would like to know whether a cite command exists in biblatex to use for having a full quotation of an article for the first quotation of the article itself, with the total page range, and another command when I can quote the first article without having the total page range.

So for example no. 1, J. Robinson, "The Missing Island", Nature 78 (2008), 123-135 and for example no. 2, J. Robinson, "The Missing Island", Nature 78 (2008), [without page range]

This is also for inquotation for instance. This would be useful in the cases you need to mention the exact pages from an article, without mention them all. The full citation would be in the bibliography in any case. The only solution I have at the moment, is of modifying in order that the full page range will not appear at all, but this means I have to retype the information as needed, instead of a command.

share|improve this question
    
Do you mean that you want to have the page range in the citation unless there is postnote containing a page range? For instance: \cite{the:article} would give the page range, but \cite[p. 325]{the:article} would not (it would just write p. 325). If so, it should be possible to implement it using \iffieldundef{postnote}. Just tell me if I understood your question correctly. –  ienissei Feb 15 '12 at 11:41
    
ienissei, you are wright, that is what I mean –  Roberto Gozzoli Feb 15 '12 at 11:52

1 Answer 1

up vote 6 down vote accepted

With the verbose-ibid style which you are using, you have a ready-made option called "citepages" available, that will do just what you want.

Try loading the package with: citepages=suppress or citepages=omit, as indicated here.

share|improve this answer
    
I thank you in advance. I have not tried the solution yet, but having read the example file, it looks it is what I wanted. –  Roberto Gozzoli Feb 15 '12 at 13:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.