Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm having a problem getting biber to process my bibliography file. I've updated my TeXLive distribution to have the following package/program versions:

biblatex 2011/11/13 v1.7
biber version: 0.9.8

When I compile this minimal example,

\documentclass{report}
\usepackage[backend=biber]{biblatex}
\addbibresource{test}

\begin{document}
    \nocite{thebook}
    \printbibliography
\end{document}

with this .bib file,

@book{thebook,
    author = "Me"
}

I get the following error:

$ pdflatex test
This is pdfTeX, Version 3.1415926-2.3-1.40.12 (Web2C 2011)
....
Transcript written on test.log.

$ biber test
INFO - This is Biber 0.9.8
INFO - Logfile is 'test.blg'
INFO - Reading 'test.bcf'
INFO - Found 1 citekeys in bib section 0
INFO - Processing bib section 0
INFO - Looking for bibtex format file 'test' for section 0
INFO - Found BibTeX data source './test.tex'
ERROR - BibTeX subsystem: C:\Users\jmert\AppData\Local\Temp\LhBA8BxHUk\test.tex_2824.utf8, line 12, syntax error: at end of input, expected "@"
INFO - ERRORS: 1

Can anyone provide any help debugging this problem? I've compiled biber from source and downloaded all the dependencies from CPAN on a Fedora 16 machine as well as used the precompiled version available for Windows on TeXLive (where the version numbers and compiler output here are taken).

share|improve this question
5  
Try again with \addbibresource{test.bib}. \addbibresource needs the file extension. This post is related. –  Audrey Feb 16 '12 at 5:44
1  
Thank you, @Audrey, that did it. I guess I didn't read the BibLaTeX manual close enough to know that I needed the .bib extension; I just assumed it was like most other TeX commands that you were supposed to leave off the extension so that the underlying drivers could choose the appropriate file. Thanks again! –  jmert Feb 16 '12 at 16:15

2 Answers 2

There is actually an optional datatype parameter for \addbibresource that allows you to specify the format of the bib file.

According to the biblatex manual, the formats are bibtex, ris, zoterordfxml and endnotexml. In the most recent versions, there is also an experimental biblatexml, which you can read about here:

How to create multilingual (English, Japanese) bibliographies with biblatex, biber and polyglossia

http://sourceforge.net/apps/mediawiki/biblatex/index.php?title=Multi-script_support

share|improve this answer
up vote 2 down vote accepted

I just wanted to leave an official answer to the problem as a proper post so that others may find it useful in the future. This error is particularly cryptic (giving no indication as to where the actual problem exists), and Google searches gave me no leads.

Audry gave the correct answer above; the solution was to add the .bib extension the bibliography file name in the \addbibresource command. I wrongly assumed that the command was like \include or \includegraphics where it works/is suggested that you leave off the file extension.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.