Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to transition to Latex Suite for Vim, but it seems to have several problems, observe: Latex Suite Screenshot

The first \subsection command (90) is shown but the second one (124) is not. Again the third one is (132), but the fourth one isn't (154). A similar problem exists for the figure (163). There is other strange behaviour too, sometimes the \begin{itemize} doesn't fold at all, other times, only its individual items fold.

There seems to be no method to this madness, if I issue any of the commands

  • za
  • zM
  • zR

nothing really changes. If I have word wrap set, folding and unfolding might result in the entire line disappearing (until I scroll down).

Is this problem specific to me (ie. am I using it incorrectly, installed it incorrectly...) or is Latex-suite unreliable?

share|improve this question
    
zE deletes all folds –  cmhughes Feb 17 '12 at 3:59
    
@cmhughes these 'folds', they exist in memory right? As in if I reopen the file (or press F6... which doesn't work for me btw) then I get them back right? –  puk Feb 17 '12 at 4:59
    
@cmhughes WOW doing zE then reloading the file works! Is there any way to do it without reloading the file? –  puk Feb 17 '12 at 5:03
    
In a comment to my answer you stated that you have problems with your VIM configuration. Are you sure that what you percieve isn't effectively a problem with your local setup? –  DevSolar Feb 17 '12 at 15:45
    
@DevSolar No the configuration issue was with remapping ; and :. That might be why F6 and \rf don't work, but I don't think it has anything to do with folding. In any case, I removed the option as you suggested as it is distracting. –  puk Feb 17 '12 at 21:34
add comment

1 Answer

Not a "solution" to your problem, but I found the folding feature to be mostly in the way.

The line

let g:Tex_AutoFolding = 0

in my ~/.vimrc "solved" that problem for me. ;-)

share|improve this answer
    
you mean you manually reset the fold? via \rf I suppose? I am running into problems with my .vimrc file. A lot of commands like \rf or F6 are not working for me so I can't test that out –  puk Feb 17 '12 at 5:49
    
@puk: No, I don't use folding at all. I use the above .vimrc line to keep LaTeX Suite from folding files on opening them. (I feel that folding stuff away from view is more a hindrance than a help, both with LaTeX and programming source.) –  DevSolar Feb 17 '12 at 8:25
    
@puk: As for .vimrc troubles, since I am constantly moving between machines, I have stored my .vimrc configuration online. Perhaps this "known good" (and commented) configuration might help you. –  DevSolar Feb 17 '12 at 8:27
    
Impressive. Most Impressive. –  puk Feb 17 '12 at 9:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.