Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I needed to install the package xpatch which fixes a glitch in revtex4 regarding cross-referencing. However, now, every time I compile a LaTeX file the produced PDF document has the annoying sideband and is 76.9% in size. What are the instructions in the code of the .tex document that would cause the sideband to disappear and the size of the page to be, say, 150%?

share|improve this question
1  
I think this has been addressed in the comments of Werner's answer, but you should really be using revtex4-1. I am curious though; what is your reason for using REVTeX? If you're submitting to a journal, then chances are you can't use xpatch anyway. If you can use one, alternatives to REVTeX are less likely to conflict with newer packages like this. –  qubyte Feb 18 '12 at 5:39

2 Answers 2

up vote 4 down vote accepted

Will this help?

\usepackage{hyperref}
\hypersetup{
pdfstartview={FitH \hypercalcbp{\paperheight-\topmargin-0in
-\headheight-\headsep}
}}
share|improve this answer
    
Thanks Harish, that does work to make page larger. However, the sideband is still there. –  ganzewoort Feb 18 '12 at 1:18
    
Pl. refer to the documentation of hyperref for detailed control of such things. –  Harish Kumar Feb 18 '12 at 1:24

In order to remove the sidebar, use the hyperref setting:

pdfpagemode=UseNone

In order to restore the regular "Fit page width" zoom view at startup, use:

pdfstartview=FitH

Combining these gives you

\usepackage{hyperref}% http://ctan.org/pkg/hyperref
\hypersetup{pdfstartview=FitH,pdfpagemode=UseNone}

If you're interested in a 150% start view, you can use

pdfstartview={XYZ null null 1.5}

where null null refers to left top coordinates of the zoom level. That is, the top-left corner of the page in this case. For more on Acrobat menu/configurations using hyperref, see section 3.6 PDF display and information options.

share|improve this answer
    
Thanks @Werner, that really did it. –  ganzewoort Feb 18 '12 at 1:39
    
Wonder if this is the place to mention it -- xpatch seems to modify revtex4 in an unpredictable manner. The document was compiling properly until suddenly something happened and it started giving me tons of errors regarding cross-referencing. The culprit was \affiliation{}. As soon as I removed it all went well. Also, even prior to this problem it turned out impossible to use \textbf{} in the text of the sections. –  ganzewoort Feb 18 '12 at 5:04
    
@ganzewoort: But setting up a minimal revtex4 document without xpatch and using \affiliation{} also gives errors, so I don't think xpatch is the cause. I am able to include \textbf{...} inside a sectioning command without problem. Note that using certain formatting in sectioning commands with hyperref present could be problematic. Not only do these commands end up in the ToC (which should be treated with care), but they also end up as bookmarks, which is ASCII only. Hence the macro \texorpdfstring{<tex>}{<pdf>} provided by hyperref to circumvent this. –  Werner Feb 18 '12 at 5:13
    
OK, tried it with revtex4-1. That fixes the problem with \affiliation{}. –  ganzewoort Feb 18 '12 at 5:17
1  
@ganzewoort: If this seems unfixable and you think it may be related to xpatch, ask a follow-up questions - they are more than welcome! Be sure to include a minimal working example (MWE) that illustrates your problem (as opposed to code snippets). –  Werner Feb 18 '12 at 5:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.