Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've followed advice at "How to start new chapters on the right hand side" and found that including as title page, one PDF page is braking left&right orientation:

\documentclass[pdftex,a4paper,12pt,twoside,openright]{report}
\usepackage[pdftex,a4paper]{geometry}
\usepackage{pdfpages}
\usepackage{lipsum}
\begin{document}
\includepdf{onetitlepage.pdf}   % <---- problem
\begin{abstract}
Abstract \lipsum[1]
\end{abstract}
\tableofcontents
\chapter{CH1}
\lipsum[2-6]
\chapter{CH2}
\lipsum[7-8]
\chapter{CH3}
\lipsum[9]
\end{document}

After including one page PDF, I get same document, but with one more page on beginning. It's all right except one thing: right pages are now left pages.

My current workaround is to include additional empty page, like that:

\includepdf{onetitlepage.pdf}
\includepdf{oneemptypage.pdf}   % <---- current solution

Is is LaTeX-y way?

Can it be done in more elegant, LaTeX-y way?

What is the reason why including onepage.pdf breaks left&right hand side, and how to prevent it when writing documents?

share|improve this question
2  
BTW: You don't need an additional empty PDF file, specifying \includepdf[pages={1,{}}]{onetitlepage.pdf} (the {} creates a blank page) is enough - however, egreg's solution is the far better approach. –  diabonas Feb 18 '12 at 14:33
    
Thanks, your advice help me as well, because I don't want to have second page blank with "2" on bottom - instead, I prefer to have whole page empty. –  Grzegorz Wierzowiecki Feb 18 '12 at 15:00
    
However there is alternative solution for preventing header&footer : tex.stackexchange.com/questions/1681/… –  Grzegorz Wierzowiecki Feb 18 '12 at 15:03
add comment

1 Answer

up vote 5 down vote accepted

Put \cleardoublepage after \includepdf. Also, specify the notitlepage option, so the abstract will not start anew the page numbering.

\documentclass[a4paper,12pt,twoside,openright,notitlepage]{report}
\usepackage{geometry}
\usepackage{pdfpages}
\usepackage{lipsum}
\begin{document}

\includepdf{onetitlepage.pdf}
\cleardoublepage

\begin{abstract}
Abstract \lipsum[1]
\end{abstract}

\tableofcontents

\chapter{CH1}
\lipsum[2-6]
\chapter{CH2}
\lipsum[7-8]
\chapter{CH3}
\lipsum[9]
\end{document}

Never specify the pdftex option (there are cases where it's necessary, though, in connection with geometry and crop, but it's not your case).

share|improve this answer
    
Thanks. Till now I've been using \cleardoublepage before chapters. Now I know it's useful after some commands. –  Grzegorz Wierzowiecki Feb 18 '12 at 15:01
    
notitlepage help :). I didn't knew before how to deal with page reset on abstract :) –  Grzegorz Wierzowiecki Feb 18 '12 at 15:02
    
Unfortunately ones I switched to notitlepage my margins and space between lines is lost. I've made question rising this issue: tex.stackexchange.com/questions/45105/… . –  Grzegorz Wierzowiecki Feb 20 '12 at 8:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.