Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using:

\documentclass[oneside,article,openbib,12pt,titlepage]{memoir}
\usepackage[authoryear,round]{natbib} % Better bibliography support
\bibpunct{(}{)}{,}{a}{,}{,}

in the preamble of my document and

\backmatter
\renewcommand{\bibname}{References}
\bibliographystyle{chicago}   
\bibliography{listb,mybib}

in the body of the file. But a typical formatted reference is:

Freely, I. (1997).
A small paper.
The journal of small papers -1. to appear.

I've tried other non-natbib styles (e.g., regstud), and the reference flows and wraps as it should. So how does one get natbib to do the same?

Also, how does one get natbib to include the authors' entire first names?

share|improve this question
1  
Welcome to TeX.SX! The openbib option is responsible of the formatting you are getting. –  egreg Feb 18 '12 at 23:46
add comment

1 Answer

Hmmm, the bibliography output you report looks like it comes from the unsrt bibliography style, and definitely not like it's produced with the chicago bibliography style.

Please note that natbib package is a citation management package, one that lets you use employ both numeric and author-year type citation methods. (Using the author-year method is greatly simplified by using the commands \citet and \citep that are provided by the natbib package). However, the file chicago.bst is not part of the natbib package.

You may want to check why you have the openbib option among the options you specify for the \documentclass command. The openbib option used to be of relevance for LaTeX2.09-type files that had to be compiled in compatibility mode under the LaTeX2e format, but otherwise it should no longer be needed. Indeed, it would appear that specifying the openbib option creates some interference with natbib because it seems to load the unsrt bibliography style file automatically (and, worse, does so in a way that overrides your specification of chicago as the bibliography style file). Hence, do check if you really need the openbib option.

Regarding your final question: Whether the full first name of each author and/or editor is shown in the bibliography does not depend on the choice of citation manager package, but on the bibliography style file (.bst) you specify.

share|improve this answer
    
Yes, I was using \citep. Getting rid of openbib solved the problem. Thanks! –  Marsh Feb 19 '12 at 3:12
    
Thanks @Mico. Yes, I used \citep. Getting rid of openbib solved the problem. I don't remember why I added it. I think to solve a 2.09 conversion error. As for your last point, I'm a bit confused. Can I specify any .bst file with natbib? I thought natbib needs its own .bst files. I have a hard time figuring out what style file does exactly what I need. Alas, few style file names give a clue about the format unless you're already familiar with the style. (E.g., "alpha") Is there a gallery of samples somewhere? Thanks again. –  Marsh Feb 19 '12 at 3:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.