Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Does anyone has a clue why LaTeX won't adjust the font size (I changed it to 10pt, 12pt, 5pt but nothing happened):

\documentclass[10pt,landscape]{article}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[german]{babel}
\usepackage{array}
\usepackage{lscape}
\usepackage{booktabs}
\usepackage{enumitem}% for control of list spaceing
\usepackage{graphicx}
\usepackage[table]{xcolor}%coloring rows in tabluar
\usepackage{subfig}%for subfloat
\begin{document}
\newcolumntype{R}[1]{>{\raggedright\arraybackslash}m{#1}}% alignment: centered
\newcommand{\nodata}{\centering\arraybackslash --} %für -- in Tabellen

\begin{appendix}

\section{Cluster data}
\subsection{quarterly data}

%GDP
\subsubsection{Gross domestic product}

\begin{tabular}{R{3.5cm}R{3.5cm}R{3.5cm}R{3.5cm}}     %<--- damit geht es jetzt auch ;)
\toprule
\multicolumn{1}{c}{\textbf{Cluster 1}} & \multicolumn{1}{c}{\textbf{Cluster 2}} & \multicolumn{1}{c}{\textbf{Cluster 3}} & \multicolumn{1}{c}{\textbf{Cluster 4}} \\ 
\midrule

\rowcolor[gray]{.9}  Canada, France, Germany & Italy, Japan, United Kingdom, United States &\nodata &\nodata\\

  Austria, Belgium, Netherlands, Switzerland &\nodata & Luxembourg &\nodata\\

\rowcolor[gray]{.9}  Finland, Iceland, Norway, Sweden & Denmark, Ireland &\nodata &\nodata\\

 \nodata & Estonia, Hungary & Czech Republic, Slovenia & Poland, Slovak Republic \\

\rowcolor[gray]{.9}  Greece, Portugal, Spain &\nodata &\nodata &\nodata \\

  New Zealand &\nodata & Australia, Korea, Turkey & Israel \\

\bottomrule
\end{tabular}


%Plots

$\begin{array}{llll}
\includegraphics[scale=0.5]{GDPClusterPlot1.eps} & \includegraphics[scale=0.5]{GDPClusterPlot2.eps} & \includegraphics[scale=0.5]{GDPClusterPlot3.eps} & \includegraphics[scale=0.5]{GDPClusterPlot4.eps}
 \\
\end{array}$

\end{appendix}

\end{document}
share|improve this question
6  
When I run your code on my system (TeXLive 2011), except for the plots part (since I don't have your .eps files), I experience no problems with setting the default document font size to either 10pt, 11pt, and 12pt. Note that 5pt is not a recognized option for the \documentclass command. Are you maybe looking to change the font size locally, say for large tables? If so, try issuing the commands \small, \footnotesize, \scriptsize, and/or \tiny immediately before the tabular environment. –  Mico Feb 19 '12 at 13:05
    
Confirmed! ;) Thank you :) –  John Feb 19 '12 at 13:14
    
OK, I'll post my comments as an answer. –  Mico Feb 19 '12 at 13:52
add comment

1 Answer

up vote 5 down vote accepted

Please note that the options 10pt, 11pt, and 12pt of the \documentclass command set the default font size for the entire document. Some document classes, notably the memoir class, recognize additional settings for the default size of the text fonts. However, no document classes I'm familiar with recognize the 5pt option.)

To reduce the font size locally, e.g., just for a tabular environment that's too large to fit into the text block, LaTeX provides the commands \small, \footnotesize, \scriptsize, and \tiny. These instructions are relative to the document's main font size: the \small instruction reduces the font size by about 10 percent, while the \tiny instruction does so by about 50 percent. Hence, if you've specified 12pt as the default font size and if you're using one of the "standard" LaTeX document classes such as article, report, and book (or one of the document classes that are based on the standard classes), text set in a \tiny group will we rendered at 6pt.

To limit the scope of the fontsize change to the tabular environment in question, you should delimit the part of the document with a pair of curly braces, { and }. Hence, your tabular environment might now look like this:

{\footnotesize % change the font size
\begin{tabular}{ *{4}{R{3.5cm}} }
...
\end{tabular} 
} % end of scope of \footnotesize macro

Finally, if you encase the tabular environment inside a table environment, you needn't even use the braces to keep the fontsize-changing command local. Just issue the command \small, \footnotesize, etc. immediately after the begin{table} instruction (and before the \begin{tabular}{...} instruction, and the command's scope will end automatically at the \end{table} statement.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.