Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I just installed the basic version of MiKTeX 2.9 on my Windows XP system. I compile this very simple document (test.tex) with TeXworks, using the default pdfLaTeX command:

\documentclass{article}
\usepackage[dvips]{graphics}
\usepackage{xcolor}
\begin{document}
\begin{figure}[ht]
  \centering
  \input{segment.pstex_t}
  \caption{Segment $s$.}
\end{figure}
\end{document}

Where the input is a simple figure with a segment (a polyline) with a label $s$. After compiling, I get the label in the figure, but not the polyline.

share|improve this question
    
It seems like you're exporting the file from Xfig using the Language "Combined PostScript/LaTeX". This exports a .pstex_t, a .pstex as well as a .eps. Try compiling this with latex->dvips->ps2pdf rather than pdflatex. –  Werner Feb 20 '12 at 19:01
    
It is not exporting the .eps (don't know why). Should I do it manually? –  Janoma Feb 20 '12 at 19:04
    
Update: even when exporting the .eps manually, it doesn't work. Do you want me to copy the code from the .pstex and .pstex_t files? –  Janoma Feb 20 '12 at 19:07
    
First try compiling with latex->dvips->ps2pdf and see if this works. The .pstex file is most likely the same as .eps. –  Werner Feb 20 '12 at 19:09
    
I've converted my comment(s) into an answer, since this seemed to solve your problem. If you still have problems correctly setting TeXworks to automate the latex->dvips->ps2pdf compiler sequence, you could consider posting a follow-up questions. –  Werner Feb 20 '12 at 19:27

1 Answer 1

up vote 1 down vote accepted

When choosing the export Language "Combined PostScript/LaTeX", Xfig exports a .pstex_t (containing overlay text information) and a .pstex (similar to EPS format) file.

Compile your document using a latex->dvips->ps2pdf sequence to produce the correct output.


In general, you could also remove the graphicx package option dvips, since the correct driver should be detected automatically.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.