Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using the newlfm package, and want my output to use a US Letter 8.5x11 page size. Unfortunately, I'm getting A4!

I have the following documentclass declaration. The addition of "letterpaper" did not help.

\documentclass[stdletter, letterpaper]{newlfm}

I am new to LaTeX, so I'm still mostly lost. I checked a couple other projects, where the simple \documentclass{article} results in the 8.5x11 size being used.

I am using MikTex 2.8 on WinXP.

share|improve this question
    
Don't know if it matters, but have you tried removing the space in the option specification? I.e. stdletter,letterpaper instead of stdletter, letterpaper? –  Willie Wong Oct 24 '10 at 23:49
    
@Willie Wong: That should really not matter. –  TH. Oct 25 '10 at 0:13
    
@TH.: my apologies. It was late at night and I was being facetious. There is hardly enough information in the question to say anything about the answer. It is not a system-wide setting issue as \documentclass{article} gives the correct size by default, and ostensibly (by the documentation) newlfm accepts the letterpaper option. Plus I couldn't replicate the issue. So I asked myself: given the limited information, what would I have typed differently? =) –  Willie Wong Oct 25 '10 at 10:32

3 Answers 3

Oops. I see that you're using MikTeX so my answer doesn't apply.

If you are using TeX Live, try running
$ tlmgr paper
and check that everything is configured to use letter. E.g., when I run that on my computer, I see

Current context paper size (from /usr/local/texlive/2010/texmf-config/tex/context/user/cont-sys.tex): letter
Current dvipdfm paper size (from /usr/local/texlive/2010/texmf-config/dvipdfm/config/config): letter
Current dvipdfmx paper size (from /usr/local/texlive/2010/texmf-config/dvipdfmx/dvipdfmx.cfg): letter
Current dvips paper size (from /usr/local/texlive/2010/texmf-config/dvips/config/config.ps): letter
Current pdftex paper size (from /usr/local/texlive/2010/texmf-config/tex/generic/config/pdftexconfig.tex): letter
Current xdvi paper size (from /usr/local/texlive/2010/texmf-config/xdvi/XDvi): letter

You can change all of them to letter by running
$ tlmgr paper letter
You may need to be root.

share|improve this answer
    
Good info, hopefully it will help someone else. I gave it a shot, but I couldn't locate "tlmgr" on my system... –  mbmcavoy Oct 25 '10 at 1:26
    
@mbmcavoy: Yeah. tlmgr is part of TeX Live. That's why my answer doesn't apply. –  TH. Oct 25 '10 at 5:50
up vote 2 down vote accepted

After taking a break and then searching better, I came across this answer by @Stefan Kottwitz. Adding the following line to my file successfully output the correct US Letter paper size!

\usepackage[papersize={8.5in,11in}]{geometry}
share|improve this answer

According to the newlfm manual (Section 1.2), the letterpaper option to the document class should trigger the use of 8.5"x11" paper; however, it doesn't work either with my MiKTeX 2.9 -- you might want to contact the author and and let him know.

As you're resorting to geometry already, I recommend using

\usepackage[letterpaper]{geometry}

instead of manually declaring the dimensions. This is just a wee bit nicer and more "semantic". Even though I get an error message

! LaTeX Error: Command \geometry already defined.
               Or name \end... illegal, see p.192 of the manual.

it does spit out letter sized paper, so it might just work out. For what it's worth, it's definitely not going to be worse than using geometry with the explicit declaration of the paper dimensions.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.