Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm writing a thesis which is an aggregate of articles. In one article, there's a blank unnecessary page that appears between the final lines of my document and the bibliography when I put it in the thesis. I don't get this behaviour when I compiled the article separately with article class. I've tried commands like \vspace{-10cm} but to no avail. The extra page is still here. How to get rid of this page?

The thesis is a compilation of articles with each article having its own bibliography. And I'm using \include to include each article. Each article has its own \bibliography command at the end.

Thanks a lot...

updated information: I'm using the chapterbib package to put the multiple bibliographies. And the documentclass is set as:

\documentclass[fleqn,a4paper,twoside,11pt]{book}

I don't have openright option. I'm fixing this myself with adding a balnk page as necessary.

I'm putting each article as:

\begingroup

\renewcommand{\appendix}{%
\par
\setcounter{section}{0}%
\renewcommand{\thesection}{\thechapter.\Alph{section}}%
}

\input{article1}

\endgroup

See also this link: Getting correct section numbering for Appendix in a large document

share|improve this question
1  
What package are you using to get the multiple bibligraphies? By default the bibligraphies are sectioned at the level of the top-order sectioning command of the documentclass, so chapter for books and sections for articles. For book-like classes, the default is to only allow the chapters to begin on the Right-Hand-Side pages. This explains why you are seeing the extra page sometimes, but not in article. So please edit the question to include information on the documentclass you are using, and how you include multiple bibliographies. –  Willie Wong Oct 25 '10 at 10:38
    
Thanks. I've updated my post –  yCalleecharan Oct 25 '10 at 10:52
4  
Does explicitly adding the openany option make any difference? Otherwise you should try to produce a minimal but complete example that reproduces the problem and post it here. –  Juan A. Navarro Oct 25 '10 at 11:02
    
Yes it works fine! Thanks. I thought of this earlier too, tried it, but some reason I removed it. Your comment made me realized that I took it away and forgot to put it back. So yes now Bibliography can appear on either an even or odd page. Thanks a lot. –  yCalleecharan Oct 25 '10 at 11:13
    
I've given you a "great comment" vote –  yCalleecharan Oct 25 '10 at 11:13
show 2 more comments

2 Answers 2

up vote 6 down vote accepted

Try to explicitly give the openany option for your document class. My guess is that, even if you didn't specify it, your document class is using a default of openright.

share|improve this answer
add comment

Perhaps you need to give the onepage option in the documentclass?

share|improve this answer
    
Thanks. I need twopage as the thesis is a book-like document –  yCalleecharan Oct 25 '10 at 9:22
    
Indeed, this doesn't really “solve” the problem, it just changes the style of the document to one where openright/openany become meaningless. –  Juan A. Navarro Oct 25 '10 at 16:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.