TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Here is a website reference in my .bib file ...

AUTHOR = {Peston, Robert},
TITLE = {The Digital Economy Bill},
URL = {www.news.bbc.co.uk/1/hi/technology/8604602.stm},
DATE = {9},
MONTH {April},
YEAR = {2010},
ACCESSED = {8 February 2012}

When I compile and display my PDF, it only shows "Robert Peston. The digital economy bill" It does not show the URL, Date, Month, Year and Accessed. Can anyone tell me why this isn't working? I spent a while sorting this out and decided to consult help.

Also, when I compile, I get a small error "Overfull \hbox (183.18742pt too wide) in paragraph at lines 1--10". I am quite new to LaTex

share|improve this question
Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. – Martin Schröder Feb 22 '12 at 20:47
this sounds like it's dependent on the \bibliographystyle you're using in your .tex file. what is it? – barbara beeton Feb 22 '12 at 21:01
Hi Barbara. In my .tex file I'am using... \bibliography{myref} \bibliographystyle{plain} %\printindex to get my references from .bib file. – user11998 Feb 22 '12 at 21:13
@user11998: You can edit your question to include additional information. – Martin Schröder Feb 22 '12 at 21:45
You are right! Thank you :) – user11998 Feb 22 '12 at 22:04

You need to use a modern .bst file; plain.bst is not going to cut it, I'm afraid. In plain and the other "classic" BibTeX style files, the only fields contained in a misc entry that are printed out are author, title, howpublished, date, and note. All other fields -- including url and accessed -- are ignored. Hence the need for a more recent bibliography style.

Which bibliography style should you choose? Since you haven't indicated what your formatting requirements are, I can't give any definitive advice. You may want to start out with the plainnat bibliography style. (This means, by the way, that you will also need to load the natbib package, but you may be doing so already.) You should probably also be loading the url package to let LaTeX find convenient line break points in a long URL string.

By the way, the date field in a misc entry is a bit unusual. (At least that's the case when it's processed by plainnat.) For your purposes, I think it's best if you omit the date field entirely and, instead, include the day-of-the-month information in the month field; i.e., set month = "9 April" for the entry at hand.

Be aware that the misc entry (at least when used with the plainnat style) does not recognize a field named accessed. However, things will work out well if you (i) replace the accessed field name with note and (ii) place the word "Accessed" inside the note field's argument. Assuming, then, that you go with plainnat or a similar bibliography style, the bib entry should probably look something like this:

  author = "Peston, Robert",
  title  = "The Digital Economy Bill",
  url    = "www.news.bbc.co.uk/1/hi/technology/8604602.stm",
  year   = 2010,
  month  = "9 April",
  note   = "Accessed 8 February 2012",

With this entry stored in the file myref.bib, say, the following MWE

\citet{Peston2010}, \citep{Peston2010}
\bibliography{myref} % myref.bib contains the entry keyed to 'Peston2010'

produces this output:

enter image description here

Two final comments: (i) If you don't want BibTeX to lowercase the words in the title field, you should enclose the words in question in curly braces. (ii) If you want the citations generated by natbib's \citet and \citep commands to use round parentheses rather than square brackets, load the natbib package with the option "round", as in \usepackage[round]{natbib}.

share|improve this answer
Hi Mico, I'm using \bibliographystyle{plain} style. I pasted your example. And it worked, but the URL doesn't show up. I find the URL a big problem because all the references on websites do not display URL. And when I compile, I get a small error "Overfull \hbox (183.18742pt too wide) in paragraph at lines 1--10". I'm quite new to Latex. – user11998 Feb 22 '12 at 21:46
@user11998: I've applied a couple of corrections to my answer and also added a MWE and its output. I hope this will help you get you on your way. – Mico Feb 23 '12 at 2:46

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.