Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Context

I am working with Emacs 23, Auctex, Texlive 2011, biblatex-mla. My operative system is Linux Mint Lisa.

I am writing my dissertation. I use a dissertation.cls and a master document. This is part of the preamble in the master document:

\usepackage[portuguese, spanish, american]{babel}
\usepackage{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{hyperref}
\usepackage{csquotes}
\usepackage[style=mla]{biblatex}
\bibliography{thesis}

\newenvironment{mlaquote}
{\list{}{
 \leftmargin 1 in
 \itemindent 0in
 \topsep 0in
 \partopsep 0in
}\item\relax}
{\endlist}

Problem

Frequently I need to include this prenote: (qtd. in). Sometimes the following command works just fine:

\autocite[Quijano qtd. in][ 23] {Caetano1986}

the result is: (Quijano qtd. in Caetano and Rilla 23).

But in this case:

\autocite[Quijano qtd. in][44-5]{Caetano1986}.

the result is: (Quijano qtd. in 44-5)

I wonder why the autor is missing in the second case.

I think that my preamble is working fine because I am able to work with articles, books, incollections, thesis, chapters, etc, without a problem. Everything looks fine in the PDF except for some references with a prenote.

I was thinking that I had some compatibility issue between Auctex and Biblatex and I try to fix it with this post: Customising emacs to use biblatex-biber instead of bibtex But at the end, I could not fix this issue.

Here is my bib entry:

@BOOK{Caetano1986, 
title = {El joven Quijano (1900-1933): Izquierda nacional y conciencia cr\'itica}, 
publisher = {Ediciones de la Banda Oriental}, 
year = {1986}, 
author = {Gerardo Caetano and {Jos\'e Pedro} Rilla}, 
location = {Montevideo}, 
owner = {alfredo}, 
shorttitle = {Joven}, 
timestamp = {2011.04.24} 
}
share|improve this question
    
Welcome to TeX.SE! It would be helpful if you provided a bit more information about the bib entry Caetano1986, as there's possibly something in that entry that confuses \autocite. Barring that, I'd try to enclose the string 44-5 in double-quotes (") or replace it with 44f. (It's either a reference to a page number or a range of page numbers, right?) –  Mico Feb 24 '12 at 10:17
    
Just as a comment: personally I like 44--45 better than 44-5, but if there are format requirements, you have got to follow those, of course. –  Stephen Feb 24 '12 at 17:35
1  
@ad2012 The author is intentionally missing in the second citation because it's the same as the last citation. You can see this from the cite:idem bibmacro in mla.cbx. There are spacing issues with postnotes. Those might get resolved if you roll back to an earlier version of biblatex. (biblatex-mla hasn't been updated since December 2010.) –  Audrey Feb 24 '12 at 17:48
    
Hi Audrey. I will check how to install biblatex 1.0 –  ad2012 Feb 24 '12 at 18:02
    
I am following Audrey´s directions. But I don't know how to roll back biblatex. For this reason, I post this question: tex.stackexchange.com/questions/45676/… –  ad2012 Feb 24 '12 at 20:23
add comment

1 Answer

The absent author names are by design in biblatex-mla. This can get problematic if the recurrent citations are separated by a lot of text. To avoid omission of names entirely, you can redefine the cite:ibid bibliography macro. Here's an example.

\documentclass{article}
\usepackage[american]{babel}
\usepackage{csquotes}
\usepackage[style=mla]{biblatex}
\usepackage{hyperref}

\bibliography{biblatex-examples}

\renewbibmacro*{cite:ibid}{%
  \usebibmacro{cite:reset}%
  \usebibmacro{cite:mla:noibid}}

\begin{document}
\autocite[e.g.][27--45]{companion}
\autocite[e.g.][27--45]{companion}
\autocite[e.g.][27--45]{bertram}
\printbibliography
\end{document}

Here is the document compiled with biblatex 1.0.

enter image description here

For reference here's (unedited) biblatex-mla output with biblatex 1.7 and hyperref:

enter image description here

Use of both biblatex 1.0 and hyperref appears to resolve spacing issues with postnotes, but you'll have to omit any extraneous whitespace in your pre- and postnotes. For example \autocite[Quijano qtd. in][ 23]{Caetano1986} should be changed to \autocite[Quijano qtd. in][23]{Caetano1986}.

share|improve this answer
    
Audrey thank you so much. I tried to install biblatex 1.0 yesterday and after several tries and mistakes I had to reinstall TeX Live again. I appreciate your help. –  ad2012 Feb 25 '12 at 14:45
    
@ad2012 Sorry you ran into so much trouble. The cite:ibid fix works with biblatex 1.7. There might be a way to fix the spacing issues through style edits, but I don't have time to look into it. –  Audrey Feb 25 '12 at 15:22
    
Right now everything is fixed. I install biblatex (0.9a) using the TeX Live Manager. What I did was to change the repository's address back to TeX Live 2009. The manager resolve all the dependencies and everything looks in order. The spacing issues are fixed to. – ad2012 just now –  ad2012 Feb 25 '12 at 16:36
1  
I posted how I fix this problem here: tex.stackexchange.com/questions/45676/… –  ad2012 Feb 25 '12 at 17:08
    
Audrey's solution works well, but Biblatex-mla provides an additional solution built into it to avoid unclear references across paragraphs. The package option mancitepar will reset the ibid and idem trackers at every paragraph to try to avoid too much space between citations. Would it be helpful, too, to avoid ibid situations when there's a prenote defined? –  James Clawson Mar 25 '13 at 19:34
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.