Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Have to put double quotes mark for a sentence. I am using Xetex. For the input string ``The work'', the output is also ``The work'' whereas it should be “The work”. Below is the list of packages and languages I am using.

\usepackage{amssymb}
\usepackage{polyglossia}
\usepackage{amsmath}
\setdefaultlanguage{english} \setotherlanguage{sanskrit}
\usepackage{fontspec} \setmainfont{Times New Roman}
\newfontfamily\devanagarifont[Scale=MatchUppercase]{Mangal.TTF}
\newfontfamily\devtransl[Mapping=DevRom]{Times New Roman}
\usepackage{graphicx}

\begin{document}
``The work''
\end{document}
share|improve this question

1 Answer 1

Add the Ligatures=TeX option:

\setmainfont[Ligatures=TeX]{Times New Roman}

After setting this option, fontspec takes care that several characters in the input, which should produce a special ligature glyph in the output, are printed in the correct way. Now `` and '' will become “ and ”, respectively. A further example, now also -- and --- will become the en dash – and the em dash —, respectively.

share|improve this answer
    
Its working. :) thanks –  Amit Bhatt Feb 24 '12 at 7:54
2  
@AmitBhatt: Nice to read that it works for you! Perhaps mark the answer as "accepted" then, by clicking the check mark symbol at the left of the answer. –  Stefan Kottwitz Feb 24 '12 at 12:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.