Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Here's the default functionality for description items:

enter image description here

With this code

\begin{description}
    \item Lorem ipsum...
\end{description}

Is there any way to make this flush all along the left side with no automatic indentation?

share|improve this question
1  
Do you still want the small indentation the item has with respect to regular paragraphs? If it's truly flush left on every line, your items will be difficult to distinguish from regular paragraphs. And even with a small indentation on all lines, there won't be much contrast. A larger example may help show where you see a problem with the regular formatting. –  Mike Renfro Feb 26 '12 at 3:19
    
Note that using a description environment without any optional argument to \item inserts what seems to be a spurious space (\labelsep) between the margins (see Can't get my head around enumitem's spacing parameters). So, please describe what you're after exactly, since using the description environment might not be the best option available. –  Werner Feb 26 '12 at 3:36
    
@Werner I'm working on my resume [here](rwell.org/resume.pdf). In the background section, I don't want the second and third lines to be indented, but rather flush with the first line. I realized I don't need to use a {description} here, should I use something else? –  Corey Farwell Feb 26 '12 at 4:01
1  
@CoreyFarwell: I would literally just set that paragraph on its own in a raggedright environment: \begin{raggedright} I'm currently... \end{raggedright}. That should remove the paragraph indent, but still maintain your \raggeright look. Give some feedback if that doesn't work for you. –  Werner Feb 26 '12 at 4:38
add comment

1 Answer 1

up vote 5 down vote accepted

If you load the enumitem package then you can tweak this option (and many others) using a key=value approach.

In your particular case, you can use

\begin{description}[leftmargin=*]

If you want to assign this behaviour globally, you can use

\setlist[description]{leftmargin=*}

enter image description here

A complete MWE follows

\documentclass{article}

\usepackage{lipsum}
\usepackage{enumitem}

\setlist[description]{leftmargin=*}

\begin{document}
\begin{description}
    \item \lipsum[1]
\end{description}
\end{document}

See the documentation for further details: texdoc enumitem

share|improve this answer
    
I compiled your code exactly as written and it still indents after the first line –  Corey Farwell Feb 26 '12 at 3:24
    
@CoreyFarwell strange! I've added a screenshot showing how the code outputs for me. Perhaps I've misunderstood the question- Werner's comment sounds particularly relevant –  cmhughes Feb 26 '12 at 3:46
    
Alright, I'll talk with Werner. But anyways, here's the result –  Corey Farwell Feb 26 '12 at 3:55
    
@CoreyFarwell add \listfiles immediately before your \begin{document}, it sounds like your distro is out of date –  cmhughes Feb 26 '12 at 4:11
1  
@CoreyFarwell your distro is out of date- the latest enumitem is from 2011. update, re-try my code, and post back –  cmhughes Feb 26 '12 at 4:25
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.