Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Is it possible to use biblatex with the Tufte document classes (tufte-handout and tufte-book). If so, what modifications should I make to my preamble or class wrapper in order to use biblatex?


I've tried the recommended patch in a simple example:

\documentclass[nobib]{tufte-handout}

\usepackage{hyphenat}
\usepackage[backend=bibtex, natbib=true, style=numeric]{biblatex}
\addbibresource{References.bib}
\renewcommand{\cite}[2][0pt]{\sidenote[][#1]{\fullcite{#2}}}

\begin{document}

This,\cite{Sarukkai:2005} should be a side note and this\cite{Sarukkai:2005} should too.

\printbibliography 

\end{document}

But I don't get the results I should be getting (note the missing second citation):

enter image description here

(I'm also not sure how to combine this with the modifications I've already made to support abbreviated citations after the first occurrence.)

share|improve this question
    
There's some comments on this here: code.google.com/p/tufte-latex/issues/detail?id=60 –  Alan Munn Feb 27 '12 at 5:02
    
@AlanMunn: I've added an example to show what happens when I do that. –  raxacoricofallapatorius Feb 27 '12 at 5:13
    
@raxacoricofallapatorius Are you using the revised tufte-common.def? The link to it on that page is broken. Here's another one‌​. –  Audrey Mar 2 '12 at 4:11
    
@Audrey: With that the processing hangs. –  raxacoricofallapatorius Mar 2 '12 at 16:09
2  
@raxacoricofallapatorius Omit the redefinition of cite. I tried re-compiling the document here and the log is error-free. –  Audrey Mar 2 '12 at 17:19
show 3 more comments

1 Answer

up vote 19 down vote accepted

Rather than redefining the \cite command, I would use biblatex’s ability to let every citation go into a footnote (option autocite=footnote) which then will go into a sidenote (since tufte-latex uses the normal \footnote command for sidenotes). The following works for me with the tufte-common.def 3.5.2 from the tufte-latex svn repository. To override the original def file, just save the revised one as $TEXMFHOME/tex/latex/tufte-latex/tufte-common.def, where $TEXMFHOME is the path returned by kpsewhich -var-value TEXMFHOME.

\documentclass[nobib]{tufte-handout}

\usepackage{hyphenat}
\usepackage[
  style=verbose,
  autocite=footnote,
  backend=biber
]{biblatex}
\addbibresource{biblatex-examples.bib}

\begin{document}

This,\autocite{springer} should be a side note and this\autocite{springer} should too.

\printbibliography 

\end{document}

enter image description here

share|improve this answer
    
This sort of works for me. But in TeXShop, I can get this to work only (generally) after several attempts (for each build) using the "Bibliography" macro, but not the regular "Typeset" command. In LyX it won't build at all. –  raxacoricofallapatorius Feb 27 '12 at 15:18
    
@raxacoricofallapatorius, as I said: there are some error messages, so that LyX will stop compiling a PDF file. It seems as if the nobib option of the tufte class is not working correctly. However, I am not at all familiar with the tufte classes. Maybe you can file a bug report using the above example. –  domwass Feb 27 '12 at 15:41
    
@domass: See Audrey's comment above, re: the 3.5.2 tuft-common.def. –  raxacoricofallapatorius Mar 2 '12 at 20:04
    
@raxacoricofallapatorius, thanks for the hint, I edited the answer accordingly (and can compile without errors now). –  domwass Mar 5 '12 at 9:15
    
@Audrey: done (finally). I impudently made use of the wording in your comment. –  domwass Jul 25 '12 at 7:40
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.