Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've got the following Problem using the SIAM bibtex style. Consider the following bib entry

@TECHREPORT{Pap1,
  author = {Author One},
  title = {Paper Title},
  institution = {My Institute},
  year = {2011},
  number = {XXX/YY-ZZ},
  month = {December},
}

and

\nocite{Pap1}
\bibliographystyle{siam} 
\bibliography{bibfile}

to generate the bibliography. Then the output is

 A. ONE, Paper title, Tech. Rep. XXX/YY-ZZ, My Institute, December 2011.

How can I remove the "Tech. Rep." from the output? Setting type={} in the bibtex entry does not help and type={~} removes the "Tech. Rep. but inserts an unwanted whitespace before the number.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

In this particular case

type={\unskip\space},

seems to work.

share|improve this answer
    
Thanks, the output looks like I want it. –  Grisu Feb 27 '12 at 10:34
    
If i enter \unskip\space in the type-filed of Jabref, it does not remove the comma and the bibliography entry compiles like: ........University, , 21. September 2012. How can this be fixed, if using \bibliographystyle{unsrtdin} \bibliography{MyBibtexFile.bib} –  Fry Aug 21 at 16:01
    
@Fry This is specific for siam.bst; unsrtdin is a different beast. –  egreg Aug 21 at 19:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.