Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

In order to make my major folder containing my master .tex file more clean, I have set Texworks to store all auiliary files in a subfolder called auxfiles. This was done by adding the following command line -aux-directory=./auxfiles into the Arguments list for the pdfLaTex processing tool in TexWorks (detailed explanation given in: How can I put .aux files in separate folder using a command inside TexWorks?). However, after having done this BibTEx is no longer able to find the auxiliary files it needs. How do I make BibTex find the auxiliary files it needs, and in addition put its output into the auxfiles directory?

share|improve this question
    
Did you try with ./auxfiles/$basename as the argument for the BibTeX engine? What operating system are you using? –  egreg Feb 27 '12 at 21:32
    
@egreg Thanks a lot! It works fine : ) –  Espen Donali Feb 28 '12 at 10:21

1 Answer 1

up vote 3 down vote accepted

You can modify the action of the BibTeX engine in the preferences of TeXworks, so that the argument line is

./auxfiles/$basename

instead of simply $basename.

However, I suggest you to duplicate the engines: one normal BibTeX and another one, say BibTeX-AUX, that is modified in this way. Thus you'll be able to use both approaches.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.