TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am writing a document for which I need the margin to be exactly as follows: left, right, top and bottom text margin all equal to 1in, distance from bottom of the paper to page number equal to 0.75in (I don't have any footnote or header to set).

I tried to use the fullpage package in LaTeX but it does not give me the 0.75in to the page number. Is there a way to force that? I tried to set manually the margins for a 8.5x11 paper but I am not succeeding.

I tried but after writing:


I get the error message \paperwidth (0.0pt) too short.

I don't see the \paperwidth is set to 0.0pt anywhere though..

Also it seems to me that depending on which machine I use to compile my tex file, I get different margins, even when I set them up manually (without using geometry). Is it possible?

Using the geometry package things seem to work a bit better now (I changed machine and the problem with the paper width previously mentioned disappeared).


gives me without problem upper, right and left margin of 1in. But the lower margin is 1.2in and I can't change it to be 1in even by using bottom=1in or bottom=0.8in. I really don't see how this can happen. Maybe a problem with the spacing between lines? The class files I am using can be fund at http://www.math.ucla.edu/help/tex/uclathes/

I erased the margin settings of uclath12.clo as the margin I need are different from the ones that this file gives. Thank you.

share|improve this question
You should try the geometry package. For example \usepackage[margin=1in]{geometry} provides a left/right/top/bottom margin of 1in. – Werner Feb 29 '12 at 0:19
Please provide class_file.cls if you're allowed. – rdhs Feb 29 '12 at 17:05
@David I realize this is a fairly old post but I'm facing the exact same problem. Would you mind sharing the uclath12.clo that you changed (or the way you changed it) so I don't have to figure it out all myself? Much appreciated! – jan Mar 29 at 8:02

You can use geometry package.








%In the middle if you want to change the margins use





%to restore old margins, use

share|improve this answer

The problem is where in your tex file, there is no indiction of paper size. So you can add a4paper option to your geometry package option list like this:


or you can specify it in your document class options.

share|improve this answer

Expanding on Werner's comment, to get the page number's baseline 0.75 in above the page's bottom edge, use footskip:


share|improve this answer

Don't know if this is the most efficient way but this worked for me


In short \voffset is the distance from top of the page to the bottom of header portion \textheight is the total height of main text.

See this page for full understanding of above variables https://www.sharelatex.com/learn/Page_size_and_margins#Paper_size.2C_orientation_and_margins

share|improve this answer
Please do not only link to another side. Suppose, this side is not reachable, then noone can follow your thoughts. Please add an own description and or complete MWE ... – Kurt Sep 13 '14 at 18:08
will keep in mind , the diagram given in the link is very self easy to understand. – Anirudh Sep 13 '14 at 18:16
\usepackage[nohead, nomarginpar, margin=1in, foot=.25in]{geometry}

Or without a package:

\pdfpagewidth 8.5in
\pdfpageheight 11in
\headheight 0pt
\headsep 0pt
\footskip .25in
\marginparwidth 0pt
\marginparsep 0pt
\oddsidemargin \dimexpr 1in -1in
\topmargin \dimexpr 1in -1in
\textwidth \dimexpr \pdfpagewidth -2\oddsidemargin -2in
\textheight \dimexpr \pdfpageheight -2\topmargin -2in
share|improve this answer
I wouldn't recommend to do margins by hand, geometry does a fine job. – Johannes_B Mar 20 at 15:58
Also, that is not the way you set lengths in LaTeX, but plain. – Johannes_B Mar 20 at 15:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.