Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

OK, here my situation: I'm writing a paper for my class, and I want to include a bilingual bibliography since some of my sources are in Korean and I want the bibliography to show the original Korean name as well as the English title and so on.

At first I started with pdflatex, but I figured that if I want to include UTF letters it would be easier to work with XeLaTeX, so I switched over but it just doesn't want to work with biblatex/biber so far..so I hope somebody here knows how to get it working, as I've already wasted 2 days on this problem instead of actually writing my paper ^^ Heres my main file, BT.tex - in TeXworks I use the compiler XeLaTex+MakeIndex+BibTex.

\documentclass[a4paper,12pt]{article}
\usepackage{polyglossia}
\usepackage{csquotes}
\usepackage[backend=biber]{biblatex}
\addbibresource{BT.bib}
\usepackage{fontspec}
\usepackage{xeCJK}  % package for Korean fonts
\setmainlanguage{english}
\setCJKmainfont{Dotum}      % For Korean font
\setmainfont{Times New Roman}   % Standard font
\begin{document}
\section{Asymmetric Information Theory}
See \textcite{CaMa90}.
See \textcite{Ch99}.
See \textcite{BoCh96}.
See \textcite{BeSp89}.
\printbibliography
\end{document}

Here's my bibliography file:

@article{CaMa90,
author = {R. B. Carter and S. Manaster},
title = {Initial Public Offerings and Underwriter Reputation},
journaltitle = {Journal of Finance},
jourvol = {45},
year = {1990},
pages = {1045-1067}
}

@article{Ch99,
author = {M.-S. Choi},
title = {A Study on Initial Returns and Underpricing of {IPOs}},
journaltitle = {The Korean Journal of Finance},
jourvol = {12},
year = {1999},
pages = {197-226},
origlanguage = {Korean},
origtitle = {신규공모주의 공모가격 할인과 초기성과에 대한 연구},
origpublisher = {재무연구}
}

@article{BoCh96,
author = {J. R. Booth and I. Chua},
title = {Ownership Dispersion, Costly Information and {IPO} Underpricing},
journaltitle = {Journal of Financial Economics},
jourvol = {41},
year = {1996},
pages = {291-310}
}

@article{BeSp89,
author = {L. M. Benveniste and P. A. Spindt},
title = {How Investment Bankers Determine the Offer Price and Allocation of New Issues},
journaltitle = {Journal of Financial Economics},
jourvol = {24},
year = {1989},
pages = {343-361}
}

When I change the code from [backend=biber] to [backend=bibtex8] the compiler works, except that the Article Ch99 is not shown in Korean, and when I change it back to [backend=biber], the compiler does not work for me. Hope anyone can figure this one out!

Edit: I just found somebody else had (kind of) a similar problem, but I don't know how to make head and tails out of the answer..but I guess it could be helpful for you anyways! How to create multilingual (English, Japanese) bibliographies with biblatex, biber and polyglossia

Edit2: Yeah, when I compile the file using [backend=biber,style=apa], no reference list appears and the citations dont work. When I change it to [backend=bibtex8], the citations work, except that I don't know which style I have to use to include the Korean language part of the reference list. If I then change it back to [backend=biber, style=apa] (i.e. changing to biber after the .bbl file has been created using bibtex8), the reference is shown correctly in korean and english, but the volume and year of the journal are not shown anymore. I have no clue what is happening.

Edit3: When I try to compile my BT.bib using biber (don't know if that is even correct), the following console output comes up:

File/Copy.pm did not return a true value at C:/strawberry/perl/site/lib/Archive/Zip/Archive.pm line 9.
BEGIN failed--compilation aborted at C:/strawberry/perl/site/lib/Archive/Zip/Archive.pm line 9.
Compilation failed in require at C:/strawberry/perl/site/lib/Archive/Zip.pm line 254.
Compilation failed in require at -e line 358.

Edit 4: Also, my log file says:

Package biblatex Warning: Please (re)run Biber on the file:
(biblatex)                BT
(biblatex)                and rerun LaTeX afterwards.

How do I do that? I tried opening the BT.bib file, selecting biber with TeXworks, but that doesn't work (see edit 3). When I use BiBtex with TeXWorks, the created .bbl file is empty. The only method that created a .bbl file that is not empty was using [backend=bibtex8] inside my BT.tex, but that doesn't help me at all since I want to use biber and not bibtex8..

Edit 5: Furthermore, I can't even run my biber.exe from my windows command line - following error comes when I try to do so:

File/Copy.pm did not return a true value at C:/strawberry/per/site/lib/archive/zip/archive.pm line 9.
BEGIN failed--compilation aborted at C:/strawberry/perl/site/lib/archive/zip/archive.pm line 9.
Compilation failed in require at C:/strawberry/perl/site/lib/archive/zip.pm line 254.
Compilation failed in require at -e line 358.
share|improve this question
    
What's the console message when you run Biber? –  egreg Mar 3 '12 at 18:48
    
Ah, maybe I expressed myself incorrectly - the compiler works, but fails to print the Bibliography as well as the citations. –  Olorun Mar 3 '12 at 18:51
    
You should run XeLaTeX again. But the standard style you're asking for doesn't use origtitle and the other fields. –  egreg Mar 3 '12 at 18:54
    
And make sure you are not running into this: tex.stackexchange.com/questions/44006/… –  matth Mar 4 '12 at 10:33
    
I'm pretty sure it is not that problem @matth :( –  Olorun Mar 4 '12 at 16:42

1 Answer 1

You might need to change how Texworks calls Biber. I was able to get the Korean text to appear without any issue by letting Biber know that the input and output were unicode.

To modify the arugments Texworks sends to Biber open up the typesetting preferences: Edit->Preferences->Typesetting. In the Processing Tools box, select Biber then click on edit. In the window that pops up, you can add arguments. I have -U -u and $basename, all as separate entries. The "U/u" entries tell Biber that the input and the ouput are utf8.

If you routinely use non-utf8 .bib files then you can achieve the same functionality by calling biblatex in the following manner:

\usepackage[backend=biber,texencoding=utf8,bibencoding=utf8]{biblatex}

The default behavior without those arguments is that Biblatex is supposed to detect automatically the encoding of the .tex document and assume that the .bib file is the same. It might be the case, as it was for me, that biblatex needs a little reminder that it should be using utf8.

Using this set up, the I had no problems compiling the MWE you provided above. I did run into the issue of no bibliography or citations appearing when using style=apa in biblatex. I am not familiar with this style so I cannot troubleshoot what is happening here. But I was able to get Korean to appear when I set style=mla. I realize that this might not be your desired style or the style you are required to use, but it at least demonstrates that Texworks using Biblatex and Biber can process the Korean text you ask it to compile.

share|improve this answer
    
Sadly this did not fix my problem, it seems that something is wrong with my perl, as I can't even execute the biber.exe through my command line/terminal. It seems like an issue with my computer, since I can run it on my other computer without any issues (as can you apparently). –  Olorun Mar 19 '12 at 21:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.