Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

A friend asked me for help, as there have been some changes in the formatting that scrbook provides, which is not good for an updated edition of a book.

Currently, I am tweaking his sources in order to have the pdf look similar to the old version. Particularly page breaks should be consistent.

Mainly the chapter headlines seem to have changed (also the itemize parsep...) such that there are ending points in the numbers and the font seems to have gotten wider but thinner. Also the parsep after a headline has increased significantly. See pic (where I already removed the point).

picture

Does anyone have an idea how to get to the old look for the headlines?

A simple

\setkomafont{disposition}{\bfseries}

has no effect. Seems that this should already be fat...

compile output for the versions i use right now:

This is pdfTeX, Version 3.1415926-1.40.11 (TeX Live 2010)
...
(./master.tex
LaTeX2e <2009/09/24>
...
Document Class: scrbook 2010/06/17 v3.06 KOMA-Script document class (book)

please don't ask for the old version, i have no clue.

share|improve this question
    
tanks egreg! Without the pic, the question had not much meaning. –  Hecke Mar 5 '12 at 9:55
add comment

1 Answer

up vote 8 down vote accepted

Regarding the font, you could use

\setkomafont{disposition}{\normalfont\bfseries}

To modify the distance before and after a chapter heading, here are examples how you can redefine those vertical skips:

\renewcommand*{\chapterheadstartvskip}{\vspace{4ex}}
\renewcommand*{\chapterheadendvskip}{\vspace{\baselineskip}}

Regarding the thinner looking font, check if you really use the same font, which also means the encoding. For example, if you use T1 font encoding and the default fonts, it's recommendable to install the cm-super package for T1 support. If your friend did it, and you did not yet, you would notice a difference in quality.

share|improve this answer
    
Hi Stefan, thanks for your answer. I already found the Skips, but could not have them affect the numbered headlines, your example though works. Do you have an idea why exchanging \baselineskip by 1.3cm does not do the trick? –  Hecke Mar 5 '12 at 9:53
    
Unfortunately, the \setkomafont has no effect... –  Hecke Mar 5 '12 at 9:54
    
@Hecke For me it works. You could even extend it to \setkomafont{disposition}{\normalfont\rmfamily\bfseries}. The best would be if you would post a reduced copy of the document, which just shows the heading problem, so we don't need to guess about all packages and settings. –  Stefan Kottwitz Mar 5 '12 at 9:57
    
Wow, that did the trick! When 'reducing' the document i found that \usepackage[T1]{fontenc} screwed the look. At least now, when commenting it out, the headlines look fine again. Still i am wondering why this interference was not existing in the old version, but hey, problem solved. Thanks a lot! –  Hecke Mar 5 '12 at 10:04
1  
@Hecke I strongly suggest keep this fontenc line, it's important for hyphenating words with umlauts, for example. But install the cm-super package with the TeX Live Manager tlmgr - this fixes it without any changes to your document. I'm sure your friend has it installed, which explains that his version looked better. –  Stefan Kottwitz Mar 5 '12 at 10:25
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.