Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I recently upgraded from MacTex 2009 to MacTex 2011. Before installing 2011, I carefully followed the instructions for uninstalling 2009 that were given here.

After installing 2011, I ran sudo tlmgr update --all

Then, I tried to test the installation by compiling an old paper that I had written using Xetex and BibLaTeX. This is when I noticed that there was no BibLaTeX binary installed on my system.

So, I tried tlmgr show biblatex, which reported that the package was indeed installed on my system. I also tried texdoc biblatex, which also brought up the BibLaTeX manual. Finally, I tried tlmgr search --file biblatex. This showed that a number of files were installed with the biblatex package, but, curiously enough, no binary file.

My next step was to try to uninstall and reinstall the biblatex package by running sudo tlmgr remove --force biblatex and sudo tlmgr install biblatex

After this, I tried tlmgr show biblatex, texdoc biblatex, and tlmgr search --file biblatex, as before, with exactly the same results.

So, my question is: Where is the biblatex binary? How do I process my biblatex files now?

Any help that anyone can give would be greatly appeaciated!

share|improve this question
    
Can you place the error you get when you try to compile with biblatex into the question please? Include a minimal working example. I'm running MacTeX 2011 on multiple systems and this has never been an issue. In addition, biblatex uses BibTeX or biber as the back end. Are you really talking about one of these? There is (as far as I know) no binary file associated with biblatex. –  qubyte Mar 7 '12 at 5:02
    
So, mucking about on tex.sx, I managed to find out a little bit more information. The paper that I was trying to recompile was using biblatex-chicago. I had this package configured to use bibtex as the backend. But, a little bit of research revealed that biblatex-chicago now requires biber for the backend. So, I changed the configuration in my document from: \usepackage[backend=bibtex8,babel=other]{biblatex-chicago} to \usepackage[backend=biber,babel=other]{biblatex-chicago} Then I was able to run xelatex paper; biber paper; xelatex paper; xelatex paper, and it worked. –  Peter Totleben Mar 7 '12 at 5:06
    
The problem was that there was a biblatex command that I had vim-latex configured to run when I was using MacTex 2009. Perhaps this wasn't really a binary -- but it's immaterial now. –  Peter Totleben Mar 7 '12 at 5:09
    
Ah, answered before I read these. Check it out anyway, as the script I mention can automate the choice of BibTeX or biber from a directive you can write into your document. –  qubyte Mar 7 '12 at 5:15
    
Possible duplicate of What to do to switch to biblatex?. See lockstep's answer for some information on using biber and the changes necessary. –  qubyte Mar 7 '12 at 7:31

1 Answer 1

I suspect that you're not using biblatex in quite the right way. In your preamble, place biblatex in as a package with some options. You can find out more about these options from the manual. For example:

\usepackage[style=nature,backend=biber]{biblatex}

Loads biblatex and tells it to use biber as the backed. You'll now need to tell it where to find the BibTeX database.

\addbibresource{YourBibliography.bib}

finally, wherever you want the bibliography placed, use this command:

\printbibliography

Remember, you'll need to do the standard latex (whichever variant you use) one of biber (not BibTeX unless you told biblatex to use BibTeX) or bibtex, and finally two more runs of latex. If you use TeXShop (or actually any editor), you may find this script I wrote handy.

share|improve this answer
    
I think you made a small mistake, normally one needs pdflatex-bibtex-pdflatex-pdflatex, not the other way around. Also, when using biblatex only one run of pdflatex is necessary after biber/bibtex. –  Torbjørn T. Mar 7 '12 at 7:00
    
@TorbjørnT. Whoops, how embarrassing! Fixed now. –  qubyte Mar 7 '12 at 7:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.