Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to have this LaTeX document class code produced by LyX:

\documentclass[english]{lni}

My Layout class looks like this:

#% Do not delete the line below; configure depends on this
# \DeclareLaTeXClass[lni]{article (LNI)}
# Input general definitions
Input stdclass.inc

The custom LNI class defaults to German. It is installed properly and works fine but I get some German output (e.g., "Literatur" instead of "References"). According to the LNI guide, passing the [english] parameter is required for english output.

How do I change it to add the layout file to support the [english] parameter?

share|improve this question

closed as too localized by Torbjørn T., lockstep, Joseph Wright Mar 20 '12 at 21:38

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Problem solved. No need to deal with it in the layout. Just set Document>Settings>Language>Language package to "Default" instead of "None". –  Juve Mar 8 '12 at 10:14

Browse other questions tagged or ask your own question.