Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have started writing my report using LaTeX. I have hid the page numbers for the first pages, table of contents included. However, after table of contents page numbers seems to be above the lowest point that the content reaches. I am using

\documentclass[a4paper,12pt]{article}
\usepackage{fullpage}
\title{\bf Title\vspace{2cm}}
\author{\emph{Author:}\\author\vspace{0.5cm} \\ \emph{Supervisor:}\\supervisor\vspace{2cm}}
\date{\today}
\begin{document}
\maketitle
\thispagestyle{empty}
\newpage
\begin{abstract}
\end{abstract}
\thispagestyle{empty}
\newpage
\renewcommand{\abstractname}{Acknowledgements}
\begin{abstract}
\end{abstract}
\thispagestyle{empty}
\newpage
\thispagestyle{empty}
\tableofcontents
\thispagestyle{empty} \newpage
\setcounter{page}{1}

and resetting counter after ToC like this :\setcounter{page}{1}
What do i have to change in order the page numbers to appear below my text?

share|improve this question
    
Please add to your question a minimal working example illustrating the problem mentioned. –  Gonzalo Medina Mar 8 '12 at 1:10
    
The code you just posted doesn't reproduce the problem you mentioned; please add a proper minimal example. –  Gonzalo Medina Mar 8 '12 at 1:44
add comment

2 Answers

I agree with recluze regarding the selection of document class. You should not be using article class for a report.

However, if you want the page numbers to be uniformly placed at a particular height you can use geometry package (footskip=.25in) along with fancyhdr.

\documentclass[12pt,oneside]{book}
\usepackage{fancyhdr}%<-------------to control headers and footers
\usepackage[a4paper,margin=1in,showframe,footskip=.25in]{geometry}
\usepackage{lipsum}
\title{Title of the report}
\author{your name}
\begin{document}
\maketitle
\fancyhf{}
\fancyfoot[C]{\thepage} %<----to get page number below your text
\pagestyle{fancy} %<-------the page style itself
\frontmatter
\tableofcontents
\mainmatter
\chapter{First chapter}
\section{One}
\lipsum[1-3]
\section{Two}
\lipsum[1-13]
\chapter{Second chapter}
\section{One}
\lipsum[1-3]
\section{Two}
\lipsum[1-13]
\backmatter
\end{document}

enter image description here

You may remove showframe from geometry options in the final version.

share|improve this answer
add comment

To write a report, you should use the report document class (or memoir if you want better output. I prefer it myself.) Use the memoir manual to find out how to separate frontmatter, mainmatter and backmatter. That should solve all the numbering issues.

If you want to hide the TOC from the TOC itself, use \section*{Table of Contents} (or \chapter*{Table of Contents} if you're using report or memoir). Then, post any follow up questions.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.