Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to make the program for my wedding. Basically what I want is for each program to be a single sheet of A3 printed front and back in landscape orientation and folded into three panels. This being a kind of fancy affair, I'd like to use my nice Hoefler font for the main text and the nice small caps. Here's the minimal example:

\documentclass[a3paper]{leaflet}
\usepackage{lipsum}
\usepackage{fontspec}
\setmainfont[Mapping=tex-text, Numbers=OldStyle]{Hoefler Text}
\setsansfont[Scale=MatchLowercase,Mapping=tex-text]{Hoefler Text}
\begin{document}
\lipsum\lipsum\lipsum\lipsum
\end{document}

This document will compile with xelatex, but it apparently overrides the A3 paper setting back to default letter paper size and shifts the orientation back to portrait. If I comment out the lines about fontspec and the font setting commands the document and compile with latexmk, then it comes out just fine. Apparently some people have run into similar problems when using the hyperref package with the leaflet class.

Anybody got any ideas how to fix this?

share|improve this question
    
Never mind. I figured out what I needed to do. If I change the driver to dvips it works. Just in case anybody else runs into the same issue change the first line in the above to: \documentclass[dvips,a3paper]{leaflet} –  shane Mar 12 '12 at 2:22
    
Have you tried the geometry package.? (\usepackage[a3paper,left=1in,right=1in,top=1in,bottom=1in]{geometry} –  Harish Kumar Mar 12 '12 at 2:23
1  
You can either answer your own question or flag/vote it for closing. For archival reasons, we are trying to keep the unanswered questions as fewer as possible. –  percusse Mar 12 '12 at 2:31
add comment

1 Answer 1

Loading graphics with the dvips driver when you are actually using xetex is asking for trouble. One shouldn't lie about the driver used. I would suggest to set the pdfpaper sizes:

\documentclass[a3paper]{leaflet}
\pdfpagewidth=420mm
\pdfpageheight=\paperheight
\usepackage{lipsum}
\usepackage{fontspec}
\begin{document}
\lipsum\lipsum\lipsum\lipsum
\end{document}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.