Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am not sure if this should be here or whether I should create a bug report. I am trying to use the bbm package as per this example:

\documentclass{article}
\usepackage{bbm}
\begin{document}
$\mathbbm{A}$
\end{document}

but I get the following error:

This is pdfTeX, Version 3.1415926-2.3-1.40.12 (TeX Live 2011)
 restricted \write18 enabled.
entering extended mode
(./minimalbbm.tex
LaTeX2e <2011/06/27>
Babel <v3.8m> and hyphenation patterns for english, dumylang, nohyphenation, uk
english, usenglishmax, loaded.
(/usr/local/texlive/2011/texmf-dist/tex/latex/base/article.cls
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(/usr/local/texlive/2011/texmf-dist/tex/latex/base/size10.clo))
(/usr/local/texlive/2011/texmf-dist/tex/latex/bbm-macros/bbm.sty)
(./minimalbbm.aux)
(/usr/local/texlive/2011/texmf-dist/tex/latex/bbm-macros/ubbm.fd)
kpathsea: Running mktextfm bbm10
/usr/share/texlive/texmf/web2c/mktexnam: Could not map source abbreviation  for bbm10.
/usr/share/texlive/texmf/web2c/mktexnam: Need to update ?
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input bbm10
This is METAFONT, Version 2.718281 (TeX Live 2011)


kpathsea: Running mktexmf bbm10
! I can't find file `bbm10'.
<*> ...e:=ljfour; mag:=1; nonstopmode; input bbm10

Please type another input file name
! Emergency stop.
<*> ...e:=ljfour; mag:=1; nonstopmode; input bbm10

Transcript written on mfput.log.
grep: bbm10.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input bbm10' failed to make bbm10.tfm.
kpathsea: Appending font creation commands to missfont.log.

! Font U/bbm/m/n/10=bbm10 at 10.0pt not loadable: Metric (TFM) file not found.
<to be read again> 
                   relax 
l.6 $\mathbbm{A}
                $
?

FYI: I am running Fedora with TeXlive 2011 installed manually and I have run

$ tlmgr install bbm-macros

but there is no poackage bbm available:

$ tlmgr search bbm
bbm-macros - LaTeX support for "blackboard-style" cm fonts.

It seems that this might be the problem. In the Fedora TeXlive there is a package texlive-bbm and a package texlive-bbm-macros -- the former containing the cm-fonts.

share|improve this question
    
I got this working by downloading the archive here and manually unpacking it into /usr/local/texlive/2011/texmf-dist/tex/latex/bbm then running tlmgr update --all. –  Stephen Mc Ateer Mar 14 '12 at 22:32
    
It would be nice if somebody with a manual install of TeXlive 2011 can confirm that the bbm package installs fine for them. Then it must be just me. –  Stephen Mc Ateer Mar 14 '12 at 22:39
add comment

3 Answers

up vote 4 down vote accepted

With tlmgr show bbm I get

package:     bbm
category:    Package
shortdesc:   "Blackboard-style" cm fonts.

so the bbm package exists.

I don't know much about Fedora, but if a texlive-bbm package exists, then that's what you have to install along with bbm-macros

I suggest you to do a complete install once and for all.

share|improve this answer
    
It could well be just me, see comment above. Again it is a manual install of TL2011 from the TUG website, not from the Fedora repos. –  Stephen Mc Ateer Mar 14 '12 at 22:38
    
@StephenMcAteer I always do a complete install. No reasons to spare a few hundred MiB. –  egreg Mar 14 '12 at 22:40
    
And this is an install from the TUG website (as opposed to some repo)? (I mean this one). –  Stephen Mc Ateer Mar 14 '12 at 22:42
    
@StephenMcAteer Yes. I don't know much about Fedora packaging of TeX Live, but as the stand-alone distribution requires only setting the PATH variable and adds nothing else to the system directories, I vastly prefer it to packaged versions. Not to mention that Debian one has a two year backlog. –  egreg Mar 14 '12 at 22:48
    
Then it must be just me. Thanks for the help. –  Stephen Mc Ateer Mar 14 '12 at 22:48
add comment

I managed to do a working install of bbm by

$ tlmgr install bbm

$ tlmgr install bbm-macros

Hope this helps. I'm running Mac OS X and installed TeXLive basic manually.

share|improve this answer
add comment

You need to install bbm fonts. you can get the fonts from

http://www.tug.org/texlive/devsrc/Master/texmf-dist/fonts/tfm/public/bbm/

share|improve this answer
    
See my comment above. –  Stephen Mc Ateer Mar 14 '12 at 22:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.