TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I meet a subtle problem. My simplest code is as follows. I am working in Win 7-32bit, my editor is WinEdt 7.0 (Build: 20120125 (v. 7.0)), saved as UTF-8, compiled with pdflatex(MiKTeX2.9).

\documentclass{amsart}
\usepackage[utf8x]{inputenc}

\begin{document}

\title{U}%Ü
\author{ü}
\date{\today}
\maketitle

\end{document}

The result is enter image description here, there is error message

[PLEASEINSERT\PRERENDERUNICODE{}INTOPREAMBLE]

What subtle is if I change amsart to article, or change the first U to Ü, the problem disappears.

share|improve this question
up vote 14 down vote accepted

This is due to a slight incompatibility of utf8x with amsart (that capitalizes the author's name).

You have two paths to follow:

  1. say \usepackage[utf8]{inputenc}

  2. make the offending character known to ucs and utf8x before \begin{document}

Path 1 is preferable, if you don't use characters that aren't covered by this option (and even if you do, as it's usually easy to add the needed ones).

If you stick with utf8x, then say as it's said in quite a cryptic way in the output: add

\PrerenderUnicode{ü}

in the preamble (after loading \inputenc). Add all the accented characters that might offend ucs (that's automatically loaded).

share|improve this answer
    
If I do the second option with è I get ! Package utf8x Error: MalformedUTF-8sequence. on those characters. – naught101 Sep 4 '15 at 1:24
    
@naught101 Then don't use the second option and go with the first. – egreg Sep 4 '15 at 9:15
    
I went with the second option because the first wasn't working either. In the end (after 2 days fighting it) I gave up and just replaced all of the special characters with \'e etc. I suspect it might have something to do with the American Meteorological Society journal template I had to use. – naught101 Sep 4 '15 at 12:41
    
@naught101 If so, this warrants a new question. – egreg Sep 4 '15 at 12:43

if you want to use utf8x you need to also use ucs. However utf8x has not been maintained for a long time and it is much preferable to use utf8 instead:

simply replace

\usepackage[utf8x]{inputenc}

with

\usepackage[utf8]{inputenc}

and it will display properly.

share|improve this answer
2  
ucs is loaded automatically when the utf8x option is specified. – egreg Mar 15 '12 at 23:01
1  
oh so it is. I haven't used utf8x for so long that I can't tend to forget what the issues are. – ArTourter Mar 15 '12 at 23:19
    
if I do that with a è character in the document, I get Package inputenc Error: Unicode char \u8:�t� not set up for use with LaTeX. – naught101 Sep 4 '15 at 1:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.