Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Basically I'm trying to separate multiple authors names using a comma instead of 'and', here's what I'm doing...

\documentclass[aps,prl,a4paper,twocolumn,superscriptaddress,notitlepage]{revtex4-1}
\usepackage{amsmath}
\usepackage{mathtools}
\begin{document}
\author{Thing One}
\author{Thing Two}
\affiliation{Working here}
\maketitle
\end{document}

Which at the moment prints Thing One and Thing Two, instead of spacing them by a comma... Thing One, Thing Two. Any help is much appreciated!

share|improve this question
    
Welcome to TeX.SE! I've gone ahead and inserted the instruction \maketitle immediately before \end{document} in order for your MWE to produce some output. –  Mico Mar 17 '12 at 21:52

1 Answer 1

up vote 5 down vote accepted

A fairly quick solution to your issue consists of inserting the instruction

\def\andname{,} % default: \def{andname}{and}

in the preamble. (Revtex's \maketitle routine executes the macro \andname when it joins exactly two authors' names.) However, this leaves quite a bit of whitespace between the superscript marker following the first author's name and the comma. A somewhat improved look is achieved by setting

\def\andname{\hspace*{-0.5em},}

instead.

share|improve this answer
    
Thank you for the answer, such a simple fix :) –  Nick Rhodes Mar 17 '12 at 22:07
    
@Mico, could you help me? For my own reasons I need to substitute ", and" by "e". Using \def\andname{e} I get ", e". How do I get rid of the comma? –  fcpenha Feb 16 at 0:45
    
@fcpenha - I experience no odd behavior (i.e., no spurious comma) when I set \def\andname{e} as the last instruction of the preamble, i.e., immediately before \begin{document}. –  Mico Feb 16 at 6:48
    
@Mico, I get the last comma even when choosing \def\andname{}. –  fcpenha Feb 16 at 16:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.