Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I recently downloaded Kile 2.1 via the KDEwin installer. The editor runs flawlessly, except for the live preview.

In the log and messages I get an error message saying:

[Kile] Unknown tool LivePreviewPDFLaTeX.

I get this several times in a row, so I suppose Kile tries to run the live preview each time but does not find the tool.

I did a system check on Kile (Settings -> System Check...) and no critical failures were found, Okular is installed and working.

Anybody knows of this issue and has a possible solution?

share|improve this question
1  
I am having the same problem. A solution will be welcome. Thank you. –  user12771 Mar 19 '12 at 18:20
    
Welcome to TeX.sx! Your question was migrated here from Stack Overflow. Please register on this site, too, and make sure that both accounts are associated with each other, otherwise you won't be able to comment on or accept answers or edit your question. –  Werner Apr 3 '12 at 2:58
    
Thanks for this post, I am having the exact same problem. Resetting the configuration did not change anything. Apparently the tool "LivePreviewPDFLaTeX" is not predefined in the standard settings (It probably should be listed among all the other tools in -->settings-->configure-->tools-->build.) I tried to construct the tool myself, but this did not work so far. I will take a look in my kubuntu-based kile installation on my private computer tonight to see what the tool should look like. Heads up, N –  user13890 Apr 24 '12 at 15:57
add comment

migrated from stackoverflow.com Mar 17 '12 at 23:49

This question came from our site for professional and enthusiast programmers.

2 Answers

As stated at the bottom of this page, after the update of Kile and Okular,

it is recommended to reset the configuration of the tools. In order to do so,

  • open the tool configuration section in the configuration dialog, which can be found under Settings / Configure Kile... / Tools / Build, and
  • press the Restore Default Tools... button.

If this is not enough, check if your kilerc file is properly configured, as stated here. The steps are:

  • restore the default tools using the wizard, as stated above,
  • if needed, create manually the LivePreview tool, using the wizard in Settings / Configure Kile... / Tools / Build
  • locate the kilerc file (which can be found in %APPDATA%\.kde\share\config)
  • change the [Tool/LivePreviewPDFLaTeX/Default] section according to

this

[Tool/LivePreviewPDFLaTeX/Default]
autoRun=no
checkForRoot=no
class=LaTeXLivePreview
close=
command=pdflatex
jumpToFirstError=yes
menu=Compile
options=-synctex=1 -interaction=nonstopmode -output-directory='%dir_target' '%source'
to=pdf
type=Process
share|improve this answer
    
I tried what's suggested here and various variations, and after two hours of trying to make it work, absolutely no change. I give up. I will just stick to refreshing manually. –  ashpool Jun 8 '13 at 14:13
add comment

After such an update it is recommended to reset the configuration of the tools. In order to do so, open the tool configuration section in the configuration dialog, which can be found under Settings / Configure Kile... / Tools / Build, and press the "Restore Default Tools..." button.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.