Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to build a document with pdflatex (MikTeX) but it fails. It seems to be the used font on the title page. The error is as follows:

miktex-makemf: The md-chr7y source file could not be found.
Running ttf2pk.exe...
miktex-makepk: PK font md-chr7y could not be created.

!pdfTeX error: pdflatex (file md-chr7y): Font md-chr7y at 572 not found
 ==> Fatal error occurred, no output PDF file produced!

I found some information that this may be caused by a missing "charter" font packet. But this package was already installed and even reinstalling did not change anything.

Searching for "md-chr7y" I found three files:

MiKTeX 2.9\fonts\afm\mathdesign\mdbch\md-chr7y.afm
MiKTeX 2.9\fonts\type1\mathdesign\mdbch\md-chr7y.pfb
MiKTeX 2.9\fonts\tfm\mathdesign\mdbch\md-chr7y.tfm

Update: I checked the available updmap.cfg files for the Map mdbch.map entry. I found the entry in the file MiKTeX 2.9\miktex\config\updmap.cfg.

What else can I do to fix this problem?

share|improve this question
2  
You have to rebuild the pdftex.map file. Pressing "Update FNDB" in the MiKTeX control panel may help. –  egreg Mar 19 '12 at 9:48
    
@egreg I have already updated the FNDB - unfortunately it does not affect this problem. –  Robert Mar 19 '12 at 10:19
    
You should have a updmap.cfg file on your system, in which the line Map mdbch.map should appear. If not, you have to edit the configuration running initexmf --edit-config-file updmap from a command shell in order to add that line and then initexmf --mkmaps. At least this is what the system should have done when adding the charter package. Some expert with MiKTeX may shed some light on this: it may be necessary to use the --admin option to the two commands. –  egreg Mar 19 '12 at 10:27
    
Look in the log file and show the path that's used for the pdftex.map file. –  egreg Mar 19 '12 at 10:33
    
@egreg The map entry was present but what missed was executing initexmf --mkmaps. Thanks for the help. –  Robert Mar 19 '12 at 10:34
add comment

1 Answer

up vote 6 down vote accepted

When you add a font support package, the system should execute something similar to

initexmf --edit-config-file updmap
<add a line "Map mdbch.map">

initexmf --mkmaps

The .map file name can be different of course. If the .map file is present in the updmap.cfg file, then the second command hasn't be successful and issuing it from a command shell should solve the problem.

share|improve this answer
1  
very helpfull I am running miktex in windows 7. If you update FNDB from the control panel as admin and run the MiKTeX 2.9\miktex\bin\updmap.exe this would do the trick. I wanted this for a cv template. Lifesavers guys!! Thx –  skywalker Oct 13 '13 at 9:21
    
Thanks, @skywalker! That comment of yours just helped me (more than the answer that you commented on, though I would have tried the answer next if your point-and-click solution hadn't helped...) –  Stephan Kolassa Nov 9 '13 at 16:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.