Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've noticed that using

\usepackage[utf8]{inputenc}

my quotation marks are ignored. I've used " in my source files and i would like to see the same glyph(?) in my output file.

I saw i should use latin1 instead of utf8 but this create another problem: my files are encoded in UTF-8 and i can't understand how to convert them to ISO-8859 in Windows.

I would like to receive suggestions on how to solve this without going through my text to change hundreds of quotation marks.

share|improve this question
5  
Quotes should never be input with ", but rather with `` for the opening quotes and '' for the closing ones. –  egreg Mar 19 '12 at 12:02
    
that's the problem, in italian there are no opening and closing quotes, otherwise it would be easier. –  Chobeat Mar 19 '12 at 12:05
1  
If you want to use guillemets, then << and >> work if you say \usepackage[T1]{inputenc} –  egreg Mar 19 '12 at 12:10
    
those does not exist in italian too... –  Chobeat Mar 19 '12 at 12:15
6  
@Chobeat I’m Italian and I use quotes all the time: there are different forms for opening and closing. One can choose between “English quotes” or «French quotes», as long as the usage is consistent, but the "straight quotes" are definitely wrong in fine quality printing. –  egreg Mar 19 '12 at 13:32

2 Answers 2

up vote 4 down vote accepted

Are you using babel with shorthands? Also a minimum working example would help ...

Added:

\documentclass{article}
\usepackage[italian]{babel}
\begin{document}
\shorthandoff{"}    

    "

\end{document}

works. See the babel documentation.

If you actually want to show a "neutral" quote glyph, you could try something along these lines:

\documentclass{article}
\usepackage[italian]{babel}
\usepackage[T1]{fontenc}
\begin{document}
\shorthandon{"} 
\def"{\textquotedbl}
"i".
\end{document}

Beware: this is a horrible thing to do, and it may break other parts of your document.

share|improve this answer
    
i'm using \usepackage[italian]{babel} –  Chobeat Mar 19 '12 at 12:15
    
i know it's horrible but for now it's the best solution. Anyway "\def"{\textquotedbl}" doesn't work. I think i can understand what it does, but i can't find out why it doesn't work. –  Chobeat Mar 19 '12 at 13:16
1  
@Chobeat: you need to compile the whole thing for this answer to work, not just the 6th line. Specifically, you need to load fontenc. –  Koji Mar 19 '12 at 13:19
    
solved, i had to switch \shorthandon with \def –  Chobeat Mar 19 '12 at 13:23
    
@Chobeat: Are you compiling the above document, as shown? –  Koji Mar 19 '12 at 13:23

In the babel package with "italian" as the language setting, you can use the shortcuts "< and "> to produce left-hand and right-hand guillemets. If you're not happy with the look of the resulting guillemets, you could use the \enquote{...} command of the csquotes package to produce guillemets that are slightly more curved (relative to what's produced by the babel method) and are also spaced slightly further apart.

The two guillemet forms are produced in the MWE below.

\documentclass{article}
\usepackage[italian]{babel}
\usepackage[T1]{fontenc}
\usepackage[autostyle]{csquotes}
\begin{document}
"<Buona sera, signorina">        \qquad \,via babel's \verb|"<| \ldots \verb|">|

\enquote{Buona sera, signorina}  \qquad via \verb|\enquote{...}|
\end{document}

enter image description here

share|improve this answer
2  
To whoever downvoted this answer: I'd appreciate if you'd leave a comment as to what you disagree with or otherwise find deficient. If you downvoted the answer by accident and would like to reverse this action, please feel free to do so. Thanks in advance. –  Mico Mar 19 '12 at 15:32
3  
It's quite strange that this answer, which is correct, got a downvote. –  egreg Mar 19 '12 at 19:03
    
@egreg: The downvote doesn't need to be intended. I downvoted you by accident two days ago when I was looking at tex.stackexchange on my smartphone. I would never have realized it if I hadn't got a badge for it (after which I could undo it). –  Ulrike Fischer Mar 20 '12 at 8:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.