Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've got problems making TexMaker / MikTeX 2.9 use polish hyphenation rules. As from what I've read on this forum (e.g. here), babel package should automatically load polish hyphenation rules after setting:

\usepackage[polish]{babel}

but it doesn't seem to do so. Until now, I always end up creating a long list of

\hyphenation{ wordslist }

in the preamble to correct for mis-hyphenated words. Isn't there a way to configure babel / TexMaker / MikTeX to load a specific file, i.e. hyph_pl_PL.dic? I recall such a possibility in TeXnic Center (correct me if I'm wrong).

share|improve this question

closed as too localized by lockstep, Paulo Cereda, egreg, Peter Grill, Stefan Kottwitz Apr 24 '12 at 16:32

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Check in the .log file for a "No hyphenation patterns" message. –  egreg Mar 20 '12 at 8:46
    
Go to the MiKTeX Settings in your start menu and check if polish is enabled. Then, babel should work as you directed it. Texmaker has nothing to do with hyphenation in your document, and neither has TeXnicCenter. They only provide spell-checking for your source code. –  doncherry Mar 20 '12 at 8:46
    
Yes, Polish is enabled. Nevertheless some (pretty many) words get hyphenated wrong. Can it be the problem is OS specific? I just installed TexMaker on Windows (created the question while on Linux) and hyphenation looks OK –  mmm Mar 20 '12 at 14:04
    
@egreg .log states hyphenation for polish is loaded –  mmm Mar 20 '12 at 14:05
    
@mmm Can you produce some examples, please? My suspect is that you're inadvertently changing the language. –  egreg Mar 20 '12 at 14:06

Browse other questions tagged or ask your own question.