Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Is this intended behavior (with plain XeTeX):

\input tikz
\tikz\draw[dashed] node {$3T\over4$};
\bye

It renders as: enter image description here!?

The fraction line is dashed, too! Is this intentional? Is there something I can do to change that? I know I can separate the fraction into its own node, but other than that?

share|improve this question
1  
I can't reproduce this. When I run the file through TeX and view the DVI it's just a regular line, same when I then convert it to pdf and view that. –  Roelof Spijker Mar 21 '12 at 14:37
    
@RoelofSpijker: A-ha! It doesn't happen with pdftex, but with xetex. –  morbusg Mar 21 '12 at 14:40
    
Status no repo. Tried with LaTeX running pdflatex, tried also with tex on the commandline with your exact code. Both times, I get a good solid line across. Could it be a version issue? –  Loop Space Mar 21 '12 at 14:40
    
Okay, I get it with xe(la)tex. –  Loop Space Mar 21 '12 at 14:41
    
@AndrewStacey, RoelofSpijker: I've edited the question accordingly. –  morbusg Mar 21 '12 at 14:46

1 Answer 1

up vote 7 down vote accepted

At a guess, what's happening is that the dashed is getting applied to a low-level scope which includes the horizontal line from the fraction. So, without knowing the gory details, there's some conversation something like:

  • TeX: Okay, we're drawing dashed lines here
  • PDF: Right, setting lines to dashed
  • TeX: Now, we need to draw a fraction
  • PDF: A what?
  • TeX: I mean, draw a 3T a little high, a 4 a little low, and draw a line in between
  • PDF: Gotcha, oh and I presume that the "dashed" still applies to the line

Presumably in other systems, the method for drawing the lines from PGF and the lines from other stuff don't end up mixed like that.

A proper solution would involve sorting out the scoping so that the dashed doesn't apply to the line. A hack is to negate the dashed when processing the node. Being me, I'm going for the hack:

\input tikz
\tikz\draw[dashed] node[solid] {$3T\over4$};
\bye
share|improve this answer
    
Andrew, I'm very happy with this solution, thank you very much! –  morbusg Mar 21 '12 at 15:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.