Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Take the template.tex example file from http://www.ctan.org/tex-archive/macros/latex/contrib/moderncv/examples and add these two lines:

\usepackage{fontspec}
\setsansfont{Linux Biolinum O}

Then run it with lualatex. Suddenly these thick bars get really slim. Why is that?

change in line thickness

Example:

\documentclass[11pt,a4paper,sans]{moderncv}  
\usepackage{fontspec}
\setsansfont[Ligatures=TeX]{Linux Biolinum O}

\moderncvstyle{casual}        
\moderncvcolor{blue}          
\usepackage[scale=0.75]{geometry}


% personal data
\firstname{John}
\familyname{Doe}
\title{Resumé title (optional)}               
\address{street and number}{postcode city}   

\begin{document}

\maketitle

\section{Education}
\cventry{year--year}{Degree}{Institution}{City}{\textit{Grade}}{Description}  
\cventry{year--year}{Degree}{Institution}{City}{\textit{Grade}}{Description}


\nocite{*}
\bibliographystyle{plain}
\bibliography{publications}             

\end{document}
share|improve this question
    
Minimal Example: paste.ideaslabs.com/show/zVgB7cbSWD –  bioslime Mar 21 '12 at 17:40
    
Weird, your mwe looks fine for me with either Biolinum or Libertine. –  ArTourter Mar 21 '12 at 17:49
1  
Now im confused. I use MacOSx & TexShop (MacTex Bundle). Simply switching from Lulatex (wired slim bar) to Xelatex (everythings fine) causes the difference. –  bioslime Mar 21 '12 at 17:54
    
This has nothing to do with moderncv in particular. I've posted a minimal example as an answer (although it's not exactly.) –  Alan Munn Mar 21 '12 at 19:37

2 Answers 2

up vote 6 down vote accepted

Here's a more minimal example. The problem is that LuaTeX and XeTeX use different methods for finding fonts, and as a result, LuaTeX is finding the version of the font which is in /usr/local/texlive/2011/texmf-dist/fonts/opentype/public/libertine/ while XeLaTeX is finding the font in /Library/Fonts. If we load the font using its actual filename (which is possible with LuaTeX) the correct behaviour can be seen depending on the name of the font:

Given that the version in TeXLive is newer than the one (that I have) in /Library/Fonts/, it seems that the newer font is the one with the incorrect behaviour.

% !TEX TS-program = LuaLaTeX


\documentclass{article}
\usepackage{fontspec}
\begin{document}    
\fontspec{LinBiolinum_Re-0.6.4}
Biolinum in \texttt{/Library/Fonts}

\rule{1in}{1ex}
\rule{1in}{4.5pt}

\fontspec{LinBiolinum_R}
Biolinum in \texttt{/usr/local/texlive/2011/texmf-dist/fonts/opentype/public/libertine/}

\rule{1in}{1ex}
\rule{1in}{4.5pt}
\end{document}

output of code

share|improve this answer
    
Works fine for me, but I remember that there was a libertine version where the ex-values were faulty. –  Ulrike Fischer Mar 21 '12 at 19:56
    
@Ulrike What versions of the fonts do you have? –  Alan Munn Mar 21 '12 at 20:04
1  
@Alan Thanks, that clarifies a lot. Wicked thing is that the texlive2011 version appears to be the newest. The newest package (LinLibertineOTF_5.1.3_2011_06_21.tgz) from sourceforge shows up in Apples Font Book as -> FontForge 2.0 : Linux Biolinum O : 21-6-2011. And this version results in the thin/thick effect. –  bioslime Mar 21 '12 at 20:55
1  
Apparently the problem persists for quite a while now. This might come in handy: latex-my.blogspot.de/2011/10/… –  bioslime Mar 21 '12 at 21:01
\usepackage{fontspec}
\setsansfont[Ligatures=TeX]{Linux Biolinum O}

If you have an old TeX system (for instance, TeX Live 2009), you may need to change it into

\setsansfont[Mapping=tex-text]{Linux Biolinum O}

The Ligatures=TeX option makes XeTeX recognize the standard ligatures -- --- `` '' and some others.

share|improve this answer
    
Ah tanks, yet i actually care about the blue line besides the blue text. With other fonts it stays thick, yet gets really slim with Biolinum. –  bioslime Mar 21 '12 at 17:32
    
@bioslime Please, add a minimal example of code. –  egreg Mar 21 '12 at 17:34
    
Just added @ my first post. Simply change the font from "Linux Biolinum O" to e.g. "Linux Libertine O" and see the difference. –  bioslime Mar 21 '12 at 17:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.