Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've placed

\usepackage{glossaries}
\makeglossaries

just before

\begin{document}

as recommended in my preamble. After the main part of my paper I've placed

\newpage
\printglossaries
\newpage

before

\bibliographystyle{ecta}
\bibliography{references}
\end{document}

But the glossary won't appear. Here is what I do:

  1. Run LaTeX to load my document
  2. Run BibTex to load my bibliography
  3. Run LaTeX to generate citations and references

Before 3. I tried to run MakeIndex but then I got the following message:

Couldn't find input index file MainV2 nor MainV2.idx.
Usage: makeindex [-ilqrcgLT] [-s sty] [-o ind] [-t log] [-p num] [idx0 idx1 ...]

What do I do wrong?

I use TeXShop Version 2.43 on Mac OS 10.7., if that matters.

share|improve this question
1  
Run MakeIndex in a terminal like: makeindex -s MainV2.ist -t MainV2.glg -o MainV2.gls MainV2.glo (or simply makeglossaries MainV2 if makeglossaries is available in your system) and finally run (pdf)latex again. –  Gonzalo Medina Mar 23 '12 at 2:45

1 Answer 1

up vote 3 down vote accepted

You need to run

  1. Run LaTeX to load my document

  2. Run makeglossaries to load my Glossaries

  3. Run LaTeX to generate citations and references

share|improve this answer
    
makeglossaries was not implemented in my TeXShop. But still after implementation my glossary won't appear. I run LaTeX, then makeglossaries and get back the following message: This is makeindex, version 2.15 [TeX Live 2010] (kpathsea + Thai support). Scanning style file ./MainV2.ist...........................done (27 attributes redefined, 0 ignored). Scanning input file ./MainV2.glo...done (0 entries accepted, 0 rejected). Nothing written in ./MainV2.gls. Transcript written in ./MainV2.glg. By the way: I put all glossary-entries in a separate tex-file (Glossary.tex). –  John Mar 24 '12 at 9:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.