Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to use the erdc class for a document I've been typesetting, which currently uses the memoir class. erdc depends on mathgifg, which in turn requires Fraklin Gothic and Georgia fonts, which are TTF. These have to be installed independently, via conversion with ttf2pt1/ Unfortunately, upon installing the mathgifg.map file for assigning/mapping fonts, and copying the converted pfb files following the manual, LaTeX complains with this:

<C:/Program Files/MiKTeX 2.9/fonts/type1/itc/franklingothic/fradm.pfb>
!pdfTeX error: pdflatex (file fradmcn.pfb): cannot open Type 1 font file for reading
 ==> Fatal error occurred, no output PDF file produced!

The files are there, including fradmcn.pfb, which confuses me, since the message indicates it is "missing". I'm hitting a wall with the mathgifg package, and conversion was done with a Windows distribution of the tool with moderately recent freetype libraries.

Update: I did run updmap and texhash. The initexmf with updmap opens a completely blank config file. Is this normal? I must give a heads up on mathgifg: it comes with its own mathgifg.map file, see mirrors.ctan.org/install/fonts/mathgifg.tds.zip

share|improve this question

1 Answer 1

up vote 3 down vote accepted

TeX does not know about your new files until you tell about it. After copying the files in their proper locations (with a TDS - TeX Directory Stucture) you have to:

  1. Update the so-called “filename database”.

    In MiKTeX Navigate through the MiKTeX program: Start > Programs > MiKTeX > Maintenance > Settings > General > Refresh FNDB

  2. You have to tell the TeX about new font like this: First, edit the map configuration file updmap.cfg as follows. In a DOS Window/Command Prompt window, run:

initexmf --edit-config-file updmap

updmap.cfg file will open in a window. (in a text editor such as Notepad.)

Second, add this one line to updmap.cfg and save it:

Map newfont.map   (i.e., Map mathgifg.map)

where newfont is the font name you are trying to install (mathgifg.map). (Just click save and do not rename.)

Third, back at the DOS prompt, run:

initexmf --mkmaps

(Ignore any error messages.)

After doing this, you should remake the filename database again, as explained above; this is not always necessary, depending on your setup, but should never hurt.

For more details, refer to the source of this answer (that is where these lines are borrowed).

Then your files should be working well.

share|improve this answer
    
I'm sorry, forgot to state clearly I did run updmap and texhash. The initexmf with updmap opens a completely blank config file. Is this normal? I must give a heads up on mathgifg: it comes with its own mathgifg.map file, see mirrors.ctan.org/install/fonts/mathgifg.tds.zip –  soze Mar 23 '12 at 10:50
    
@soze Blank file is normal. In that you have to type Map mathgifg.map and save it. –  Harish Kumar Mar 23 '12 at 11:00
    
Thank you, it worked out in the end. If anyone else has trouble with this, check your user AppData folder. Any Miktex files there should be removed so the main program directory is used first. –  soze Mar 28 '12 at 23:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.