Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Tonight, right before I started trying to compile my dissertation, ConTeXt ate itself. I have determined that the maintained version of ConTeXt in the ubuntu distribution is of appropriate vintage to probably work.

My only problem is that I use the "simplefonts" module and I'm not sure how to install it within the ubuntu context.

What mechanisms exist for adding third party modules to this distribution of ConTeXt?

share|improve this question
    
Aren't Ubuntu packages based on Texlive? If so, does ubuntu provide some means of calling tlmgr? Otherwise, you can consider installing ConTeXt standalone in a parallel tree. See ConTeXt wiki for details. –  Aditya Mar 26 '12 at 14:35
    
For this problem, I couldn't run the current version of ConTeXt standalone because I was trying to work around a bug where the equivalent of includes weren't being recognized. My answer though shows my final fix. –  Brian Ballsun-Stanton Mar 26 '12 at 14:43
    
I was trying to answer your original question was "How to install third party modules in ConTeXt in ubuntu". If what you want is to install an older version of ConTeXt, please appropriately modify your question. –  Aditya Mar 27 '12 at 5:33
add comment

1 Answer

up vote 1 down vote accepted

You don't (I think).

Instead, use reverting to an older installation with the standalone to go back to an earlier version that might work.

Use: sh ./first-setup.sh --context=2011.05.18 --modules="t-simplefonts" to revert and install the module. you can't use the module command without the context otherwise the update occurs magically.

Alternatively: don't use simplefonts and just do fonts the hard way.

share|improve this answer
    
I would love it if someone gave a better answer or something. But this is what my research indicates? –  Brian Ballsun-Stanton Mar 26 '12 at 3:42
1  
it is unlikely that there will a better answer from one of the ConTeXt people, some Ubuntu expert is needed for the full question. –  Taco Hoekwater Mar 26 '12 at 8:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.