Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I use MikTeX 2.8. I want to install the greek fonts "GFS neohellenic". I open the MikTeX package manager, I type GFS neohellenic but nothing similar is found.

I downloaded the fonts from http://www.greekfontsociety.gr/pages/en_typefaces20th.html

I searched through the net for similar issues but nothing seem to be the proper one.

How can I get them to work on windows?

P.S.:I use TeXNiC CenteR

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Just install the font on your computer (e.g. C:\windows\fonts) and compile the .tex file with xelatex. The following is an example..

\documentclass[a4paper,12pt]{article}

\usepackage{xltxtra} 
\setmainfont{GFS neohellenic}

\begin{document}

asdf hjkl

\end{document}
share|improve this answer
    
Thank's a lot for your answer. I used the aforementioned code, however it's not working. I get ~400 errors. When I try to see what is wrong TXC opens a .mf file and I heve no idea what is going on, whatsoever...Let alone, it takes about to minutes to build it... –  Thanos Mar 27 '12 at 13:17
    
That's strange! I just compiled it on Texnic centre and it works. Have you configured texnic centre to work with xelatex? If not, see [here] (latex-community.org/forum/viewtopic.php?f=31&t=731). Also, please compile the above code and paste the first few errors here. –  caveman Mar 27 '12 at 13:35
    
Just out of curiosity.. have you otherwise successfully compiled a normal .tex file with standard font in Greek on Texnic centre? I have a feeling that texnic doesn't support UNICODE. I could suggest you texmaker.. it works like a charm! –  caveman Mar 27 '12 at 13:40
    
I have been using the package kerkis with TXC or the default babel. Greek letters are indeed suported by TXC. The first build says XeTeX is required to compile that document. I see... I tried to build a new profile... I have a question: What am I supposed to write on "Command line arguments to pass to the compiler"? –  Thanos Mar 27 '12 at 13:54
    
You can just choose the first option, main file's full path, as long as you don't have made some unconventional changes to your file. The code is %pm –  caveman Mar 27 '12 at 14:04

These are OpenType (OTF) fonts. Install them in your windows system font folder and use them with xelatex/lualatex + the fontspec package.

share|improve this answer
    
How am I going to do it? I don;t have xelatex/lualatex. I use LaTeX and TXC... –  Thanos Mar 27 '12 at 12:28
1  
@Thanos: You have xelatex. It is part of miktex 2.8. Lualatex is in miktex 2.9. –  Ulrike Fischer Mar 27 '12 at 12:43
    
I see...How am I going to use it? What am I suppossed to do to make it work?Thanks for your time! –  Thanos Mar 27 '12 at 12:51
    
Use it instead of latex. And if you search the site here you will find a lot example documents. –  Ulrike Fischer Mar 27 '12 at 12:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.