Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am a a retired software engineer and a newbie on this site. Please execuse me for the naiveness in my question.

I am using Windows, XP and Vista. Other OS's are not affordable to me for now. I used to have MikTeX 2.8 and was using the packages it came with it to draw automata. The way I used to do, was, write a .mp file and use mp.exe to preprocess it to create a graphics file and then TeXnicCenter would take it when I \usepackage{graphics}. I have a bunch of .tex files in this way.

Recently, I had to uninstall MikTeX 2.8 and replace it with MikTeX 2.9. Everything was okay when I tried it with .tex files without any graphics. When I tried to do with those with automata state diagrams, I found out mp.exe is missing from MikTeX 2.9.

I have two options,

  1. I still have the original protext.exe for MikTeX 2.8 so I can back out MikTeX 2.9 and re-install 2.8.

  2. Use TikZ to draw automata state diagrams.

I personally prefer option 1. However, option 2 seems to be the best, from all I have read on this site. But, option 2 means that I have to spend some time and efforts to learn TikZ. So, I need to know, how bad is option 1? Or, do I have option 3, that is, something compatible with mp.exe in 2.9?

share|improve this question
    
do you mean metapost? –  Harish Kumar Mar 28 '12 at 7:01
    
@Harish Kumar, yes. metapost. –  scaaahu Mar 28 '12 at 7:04
    
I think it is renamed now as mpost.exe. It is there inside C:\Program Files\MiKTeX 2.9\miktex\bin. Pl. try. I never used meta post hence it is a guess. –  Harish Kumar Mar 28 '12 at 7:07
    
@Harish, yes mpost is in bin. I just tried it. My mp files that used to work with mp does NOT work anymore. Could be some compatibility issue. Is mpost just a rename of mp? –  scaaahu Mar 28 '12 at 7:15
    
Pl. see the answer below about some bug. –  Harish Kumar Mar 28 '12 at 7:16

1 Answer 1

up vote 2 down vote accepted

Metapost is also in miktex 2.9: You can use the executables mpost.exe or miktex-mpost.exe (both are linked to the same library, and both names exists also under miktex 2.8). Only the alias "mp.exe" has disappear for some reason that I have either forgotten or never heard.

I have a faint recollection that there was some problem with metafont more or less recently. You should check the bug tracker and the archive of the miktex mailing list if something doesn't work.

share|improve this answer
    
would you point to me where the bug tracker is. –  scaaahu Mar 28 '12 at 7:17
    
sourceforge.net/projects/miktex Search for postings/messages of François Petiard. He seems to be the one who knows most about mpost. If you want me to try you will have to give me a real example file and describe exactly how you are trying to use it. I don't know enough about mpost to make such an example myself. –  Ulrike Fischer Mar 28 '12 at 7:34
    
It's fine. I can do it myself. Thanks for the help. –  scaaahu Mar 28 '12 at 9:13
    
I found the reason mpost did not work for me - I modified something before I got on this site to ask this question. A stupid mistake. After I changed back what it was, mpost works the same as mp in 2.8. Thanks to all who respond. –  scaaahu Mar 28 '12 at 10:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.