Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

The citation style authoryear-comp is designed to output citations of the form '(Doe, 1992)'. (See p. 62 of the biblatex documentation.) This has worked as expected for me, even when using Biber as backend.

Recently, however, the behavior of authoryear-comp with biblatex does not match this. Instead of outputting citations of the form (Doe, 1992), it is simply printing the title and the year of the corresponding entry.

Here's a minimal example:

\documentclass{article}

\usepackage[style=authoryear-comp,backend=biber]{biblatex}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@article{Bli74,
  author = {Blinder, Alan S.},
  year = {1974},
  title = {The economics of brushing teeth},
  journaltitle = {Journal of Political Economy},
  volume = {82},
  number = {4},
  pages = {887--891},  
}
\end{filecontents}

\bibliography{\jobname}

\begin{document}

This paper is very good: \cite{Bli74}.

\printbibliography

\end{document}

And the generated pdf:

Output using biber and authoryear-comp

Again, if I don't call Biber, biblatex behaves as expected given the citation style.

I'm using pdfTeX, Version 3.1415926-2.3-1.40.12 (TeX Live 2011), and biblatex v1.7. I get the same results using XeTeX, Version 3.1415926-2.3-0.9997.5 (TeX Live 2011).

Thoughts?

share|improve this question
    
It doesn't happen to me: I get "Blinder 1974" –  egreg Mar 28 '12 at 22:15
    
Odd. Any thoughts on what could be triggering this? –  apc Mar 28 '12 at 22:17
1  
Works for me as expected. Is your Biber version up-to-date (0.9.8)? Do you use a biblatex.cfg configuration file? Note: The citation looks as if the author field had been cleared. –  lockstep Mar 28 '12 at 22:19
    
Yes, my Biber version is up-to-date. (I've reinstalled it using the TeX Live Utility multiple times now.) The citation does look as if the author field had been cleared, but I don't know why. The author appears in the bibliography, and it appears in the citation when I don't use Biber. –  apc Mar 28 '12 at 22:34
    
@lockstep, I forgot to answer your second question. I don't use a biblatex.cfg configuration file. –  apc Mar 28 '12 at 22:37

1 Answer 1

up vote 8 down vote accepted

Looks like you're compiling the document using the backend=biber option setting, but with a bbl file generated by bibtex. biber outputs a dedicated \name for labelname. It won't find this \name from bibtex output, so the fallback title field is printed instead. You need to run latex and biber when switching from the bibtex backend. Similarly you should run bibtex when switching from biber.

Here are the \name elements for your entry from biber:

\entry{Bli74}{article}{}
  \name{labelname}{1}{}{%
    {{uniquename=0,hash=8a4ba46206eec0a36340f92bf9ee4f86}{Blinder}{B\bibinitperiod}{Alan\bibnamedelima S.}{A\bibinitperiod\bibinitdelim S\bibinitperiod}{}{}{}{}}%
  }
  \name{author}{1}{}{%
    {{uniquename=0,hash=8a4ba46206eec0a36340f92bf9ee4f86}{Blinder}{B\bibinitperiod}{Alan\bibnamedelima S.}{A\bibinitperiod\bibinitdelim S\bibinitperiod}{}{}{}{}}%
  }
...

Compare this with the output from bibtex:

\entry{Bli74}{article}{}
  \name{author}{1}{}{%
    {{}%
     {Blinder}{B.}%
     {Alan~S.}{A.~S.}%
     {}{}%
     {}{}}%
  }
...
share|improve this answer
    
Excellent! Could this be a problem with latexmk.pl? That's what I use instead of manually running latex and bibtex or biber. I ran biber manually and this fixed the problem. Thanks again, Audrey. –  apc Mar 29 '12 at 22:33
    
@apc Sorry, I don't use latexmk. You might find this post helpful. –  Audrey Mar 30 '12 at 3:25
    
Thanks, I'll take a look. –  apc Mar 30 '12 at 5:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.