Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I use quite a lot packages in my document and I cannot find which one's fault is that verbatim does not produce monospaces. Anyway, if I knew this, I have no idea how to solve problems when packages are not friendly to each other, so is there any solution with so little information?

Edited: I just tried to look how does verbatim reacts to other packages I use, and font differently changed almost with every new package, however, it looked (more or less) not so bad. So the problem is because of language I use, what probably makes my problem more difficult to solve for those, who doesn't use these.

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[L7x]{fontenc}
\usepackage[lithuanian]{babel}
\begin{document}
\begin{verbatim}
for i=0:10
    y(find(x < 0 & x > 1)) = 10;
end;
\end{verbatim}
\end{document}

Edited with new relevant situation: lithuanian caused one more font problem. I cannot get Times font with \usepackage{pslatex}, how to fix this?

share|improve this question
    
Please try and boil (a copy of) your document down to a minimum demonstrating the problem. That is, remove all content but e.g. a verbatim environment, and then remove packages one by one until you find the package or combination of packages that causes the problem. Producing such a minimal working example (MWE) is helpful both for you (in finding the error) and for those trying to help (we get info, and don't have to create examples of our own). –  Torbjørn T. Apr 1 '12 at 20:39
    
pslatex is an obsolete package. With \usepackage{tgtermes} you should get a Times clone that works with the Lithuanian encoding L7x. However this should be a different question, as the two problems are unrelated. –  egreg Apr 3 '12 at 12:57
add comment

1 Answer

up vote 11 down vote accepted

It seems that the "Lithuanian package" invoked by the L7x option doesn't set correctly the default typewriter type family: the following way to set up the document should work.

\usepackage[L7x]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[lithuanian]{babel}
\renewcommand{\ttdefault}{lmtt}
share|improve this answer
    
Great. Thanks a lot. –  Pavasaris Apr 1 '12 at 21:27
2  
@myname Try contacting Sigitas Tolušis about this; the contact can be found at vtex.lt/tex/littex –  egreg Apr 1 '12 at 21:37
    
@myname: Please accept this answer then by clicking at the tick symbol below the voting arrows. Also check your other questions. –  Martin Scharrer May 7 '12 at 13:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.