Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I was to use the package pifont to use \ding{52} in my document. However, when I use \usepackage{pifont}, I get the below error:

/usr/local/texlive/2008basic/texmf-dist/tex/latex/psnfss/pifont.sty
(/usr/local/texlive/2008basic/texmf-dist/tex/latex/psnfss/upzd.fd)
kpathsea: Running mktextfm pzdr
/usr/local/texlive/2008basic/texmf/web2c/mktexnam: Could not map source abbreviation  for pzdr.
/usr/local/texlive/2008basic/texmf/web2c/mktexnam: Need to update ?
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input pzdr
This is METAFONT, Version 2.718281 (Web2C 7.5.7)


kpathsea: Running mktexmf pzdr
! I can't find file `pzdr'.
<*> \mode:=ljfour; mag:=1; nonstopmode; input pzdr

Please type another input file name
! Emergency stop.
<*> \mode:=ljfour; mag:=1; nonstopmode; input pzdr

Transcript written on mfput.log.
grep: pzdr.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input pzdr' failed to make pzdr.tfm.
kpathsea: Appending font creation commands to missfont.log.

! Font U/pzd/m/n/10=pzdr at 10.0pt not loadable: Metric (TFM) file not found.
<to be read again> 
                   relax 
extract@font ...ont font@name external@font relax 
                                                  font@name relax csname f@e...

define@newfont ...ong@fontshape else extract@font 
                                                  fi endgroup 
pickup@font ...ifx font@name relax define@newfont 
                                                  fi 
selectfont  ...ape /f@size endcsname }pickup@font 
                                                  font@name size@update enc@...
l.62 {\Pifont{pzd}
                  }

I am not sure why I get this error. I can see the pifont.sty is present in the directory : /usr/local/texlive/2008basic/texmf-dist/tex/latex/

share|improve this question

migrated from stackoverflow.com Apr 3 '12 at 14:17

This question came from our site for professional and enthusiast programmers.

    
Welcome to TeX.sx! Your question was migrated here from Stack Overflow. Please register on this site, too, and make sure that both accounts are associated with each other, otherwise you won't be able to comment on or accept answers or edit your question. –  Werner Apr 3 '12 at 16:11

2 Answers 2

up vote 6 down vote accepted

It's after the 'pzdr.tfm' font file. Can you try locate pzdr.tfm (if you're on a unix-like system) to locate it?

For me, it appears in the following places:

/usr/local/texlive/2011/texmf-dist/fonts/tfm/adobe/zapfding/pzdr.tfm
/usr/local/texlive/2011/texmf-dist/fonts/tfm/cspsfonts-adobe/zapfding/rpzdr.tfm

Hence I think you have to install the zapfding package first (sudo tlmgr install zapfding).

share|improve this answer
    
locate pzdr.tfm returns nothing. When I try to install zapfding, I get the below error for the mirrors: tlmgr: installation location ctan.math.utah.edu/ctan/tex-archive/systems/texlive/tlnet/2008 unusable location ctan.math.utah.edu/ctan/tex-archive/systems/texlive/tlnet/2008/…, could not load any packages Cannot load TeX Live database from ctan.math.utah.edu/ctan/tex-archive/systems/texlive/tlnet/2008 at /usr/texbin/tlmgr line 2221. –  user682765 Apr 3 '12 at 0:02
    
How to you usually install latex packages? Just do that. (Could you try tlmgr update --list?) –  mathematical.coffee Apr 3 '12 at 0:19
    
Thanks. I got all the missing files (there were a couple of them missing) from tug.org/texlive/devsrc/Master/texmf-dist/fonts and now it works fine. –  user682765 Apr 3 '12 at 0:41
3  
Any reason why you are still using TL 2008? –  daleif Apr 3 '12 at 15:54

In Ubuntu precise 12.04, you should install texlive-fonts-recommended.

sudo apt-get install texlive-fonts-recommended
share|improve this answer
2  
In fedora, I used: yum install texlive-texmf-fonts, which solved the issue for me. –  zdav Jan 6 '13 at 19:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.