Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I write a paper in French, I add a package \usepackage[english,francais]{babel} to use a French but when I write:

\begin{RÉSUMÉ} abstract in french \end{RÉSUMÉ}

I get the error:

! LaTeX Error: Environment R\IeC {\'E}SUM\IeC {\'E} undefined.

and when I use:

\begin{R\'ESUM\'E} résumé en français \end{R\'ESUM\'E}

I get the same error:

! LaTeX Error: Environment R\'ESUM\'E undefined.
share|improve this question
    
I think [english,francais] should be [english,french] instead. –  Martin Scharrer Apr 4 '12 at 12:48
    
a problem becomes the same. i think i can not make RÉSUMÉ as macro ! –  user15992 Apr 4 '12 at 12:51
    
@MartinScharrer: While I'd use french as well, francais actually works, as Ulrike remarked at my answer. I was surprised as well. –  doncherry Apr 5 '12 at 15:20

4 Answers 4

Changing your language in babel doesn't change the language of the commands, it only changes the hyphenation patterns, the printed titles of e.g. the table of contents or the abstract, and, in the case of french, also the punctuation spacing (You can see below that there's space before the exclamation mark). Thus, you'll still need to use abstract as the environment's name.

While francais will work as an option for babel, I'd recommend using french instead (which does exactly the same), just so you won't get confused with the languages and keep all macros in English. Thanks to Ulrike for clarifying in the comments.

\documentclass{article}

\usepackage[utf8]{inputenc}
\usepackage[english,french]{babel}
\usepackage[T1]{fontenc}

\title{Mon titre}
\author{C'est moi}

\begin{document}

\maketitle

\begin{abstract}
Bonjour.
\end{abstract}

\tableofcontents

\section{Et voilà!}

\subsection{Bon alors}

C'est grandiose!

\end{document}

share|improve this answer
3  
In a modern installation the options french, frenchb and francais all load frenchb.ldf from Daniel Flipo. They are synonyms and it is simply a matter of taste which one you use. In (very) old systems french sometimes loaded french.sty from Bernard Gaulle. –  Ulrike Fischer Apr 4 '12 at 10:11
    
@UlrikeFischer: Ah, I didn't know nor expect that, thanks! –  doncherry Apr 4 '12 at 10:11
    
Thanks for your help ... But when i user RÉSUMÉ instead Abstract it doesn't work your solution :( i want to write like this paper : 138.96.0.43/members/Didier.Parigot/PDFarticle/francesco/… –  user15992 Apr 4 '12 at 12:17
    
I'm not quite sure, but if you want to change the abstract title (to RESUMÈ), you can use Ian's solution here. You'll still have to use abstract as the environment's name. But I think Martin's already helped you on this one. –  doncherry Apr 4 '12 at 14:10

You should not translate environment names into French, any more than you would translate \begin and \end. Use \begin{abstract} and \end{abstract}. It is possible to change the heading from 'Abstract' to 'Resume' in your document, but how you achieve this depends on the document class that you are using.

share|improve this answer

Using babel won't translate the user interface! All the macro and environment names will stay the same. I don't know whether there are packages for doing this, but babel does not.

ConTeXt allows localising the user interface AFAIK.

share|improve this answer

You can't use non-English letters in macro and environment names. The special characters are often implemented as active characters, i.e. characters which are actually macros. As you can see in the error message É is expanded to \IeC {\'E}. Such non-expandable macro can't be used in environment names.

If you want to define a RÉSUMÉ environment yourself you should use RESUME instead. Note that the babel package does not translate the names of the macros and environments, but provides hyphenation patterns and language related macros and settings, like e.g. French quotes. The default environment for this is abstract. It might be possible to translate such names to French for people which have issues with English, but even then non-English letters are a no-go.


If you want the abstract title instead by RÉSUMÉ you need to use the abstract environment nevertheless, but switch the language to french. The exact name can also be redefined manually:

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{lmodern}
\usepackage[english,french]{babel}

%\renewcommand{\abstractname}{RÉSUMÉ}
\begin{document}

\begin{abstract}
    French abstract ...
\end{abstract}

\selectlanguage{english}
\begin{abstract}
    English abstract ...
\end{abstract}

text text ...

\end{document}
share|improve this answer
3  
This is no problem in Luatex: \def\startRÉSUMÉ{} works perfectly. However, it's probably not adviasable to use and rely on such a feature. –  Marco Apr 4 '12 at 10:22
    
@Marco: Thanks, I thought that there might be a way for LuaTeX and maybe XeTeX, because they have native Unicode support. However, in general it can't be done with LaTeX. –  Martin Scharrer Apr 4 '12 at 10:25
    
then it's impossible to write RÉSUMÉ instead abstract ?? Like this paper : 138.96.0.43/members/Didier.Parigot/PDFarticle/francesco/… –  user15992 Apr 4 '12 at 12:20
3  
@user15992: You can of course get RÉSUMÉ as a headline, but there is no predefined RÉSUMÉ environment which does this. You need to use the abstract environment while the french language is active. See my updated answer for this. –  Martin Scharrer Apr 4 '12 at 12:47
    
Thanks Martin it's work :) –  user15992 Apr 4 '12 at 13:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.