Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm realty new at using LaTeX. But I have an problem getting an .bib file to show in my output:

\documentclass[]{article}
\usepackage{natbib}

\begin{document}

\title{Title}
\author{Author}
\date{Today}
\maketitle


\bibliographystyle{alpha}
\bibliography{Litteratur}

Content

\end{document}

And my Litteratur.bib looks like this:

@book{goossens93,
author    = "Michel Goossens and Frank Mittelbach and Alexander Samarin",
title     = "The LaTeX Companion",
year      = "1993",
publisher = "Addison-Wesley",
address   = "Reading, Massachusetts"
}

I'm using Latexian as my editor, and I have been into and change the setting so the type set I set to 2. And then exporting BibTeX is checked. But then I look at the log file after exporting. It's saying this:

This is BibTeX, Version 0.99d (TeX Live 2011)
The top-level auxiliary file: TSWLatexianTemp_000003.aux
The style file: alpha.bst
Database file #1: Litteratur.bib
Warning--I didn't find a database entry for "Friedl2006"
(There was 1 warning)

But I don't no where it gets that Friedl2006.

share|improve this question
2  
You mustn't specify the .bib extension. –  egreg Apr 5 '12 at 20:10
    
You have no \cite commands in your source. Without them, you will get no citations. This is covered in most LaTeX guides: perhaps take a look at tex.stackexchange.com/questions/11/… –  Joseph Wright Apr 5 '12 at 20:10
1  
I have tried to use \Cite. But the it only shows me [?] –  mortenstarck Apr 5 '12 at 20:56
2  
You have to run latex bibtex latex latex. pl try. –  Harish Kumar Apr 5 '12 at 23:36
add comment

2 Answers

up vote 4 down vote accepted

Your examples doens't show everything. I am trying to point out some relevant problems:

  • You need a specific bib file with the correct syntax. The syntax of a bib file are shown here. An other relevant question is URL of cited web site in bibliography The example is:

    @Book{abramowitz+stegun,
      author    = "Milton {Abramowitz} and Irene A. {Stegun}",
      title     = "Handbook of Mathematical Functions with
                   Formulas, Graphs, and Mathematical Tables",
      publisher = "Dover",
      year      =  1964,
      address   = "New York",
      edition   = "ninth Dover printing, tenth GPO printing"
     }
    
  • To get a reference inside your document you have to call them. For example a specific entry is called via \cite{abramowitz+stegun}. If you want to get everything of your bib file in the bibliography without citing you can simple use \nocite{*}.
  • Last but not least the compiling is important. The correct order of compiling is:

    (pdf)latex filename.tex
    bibtex filename.aux
    (pdf)latex filename.tex
    (pdf)latex filename.tex
    
share|improve this answer
    
Thanks. Instead of using \cite i used \nocite{*} instead and now it works. –  mortenstarck May 23 '12 at 0:40
add comment

Citation from the Latexian FAQ:

"I see question marks where labels and references should appear in Preview and Live Preview. What should I do?

By default, Preview and Live Preview only do a single typesetter run without any options to maximize performance (Export does multiple runs). You can configure Preview and Live Preview to do multiple runs and/or run BibTeX in the Preview section of Latexian's Preferences. Then, your labels and references should appear."

In own words: go to: Latexian --> Preferences --> Preview then under "typesetting options" mark "BibTex" and set "number of typesetting runs" to 2.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.