Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Well, I just wanted to have times render in a DVI in evince; that command failed at mktexpk, basically something like this if I try to run it standalone:

$ TEXMFCNF=/path/to/texlive/2011/texmf/web2c  mktexpk --mfmode / --bdpi 600 --mag 1+60/600 --dpi 660 ptmri7t
mktexpk: don't know how to create bitmap font for ptmri7t.
mktexpk: perhaps ptmri7t is missing from the map file.

Then I tried to updmap --enable Map times.map, then times.map doesn't exist :(.. then updmap --disable times.map, then updmap --enable Map adobe.map, than that didn't do anything, so I did updmap --disable times.map; then the same with updmap-sys... Apparently I've pasted also updmap-sys --enable Map fourier.map, so I disabled that too updmap-sys --disable fourier.map - and now, I'm at a point where pdflatex started spitting this out:

pdfTeX warning: pdflatex (file /home/USER/.texlive2011/texmf-var/fonts
/map/pdftex/updmap/pdftex.map): ambiguous entry for `zpcp32bc': font file prese
nt but not included, will be treated as font file not present


pdfTeX warning: pdflatex (file /home/USER/.texlive2011/texmf-var/fonts
/map/pdftex/updmap/pdftex.map): ambiguous entry for `zpcp33bc': font file prese
nt but not included, will be treated as font file not present


pdfTeX warning: pdflatex (file /home/USER/.texlive2011/texmf-var/fonts
/map/pdftex/updmap/pdftex.map): ambiguous entry for `zpcp33bc': font file prese
nt but not included, will be treated as font file not present

I tried also updmap-sys --force --syncwithtrees (and updmap --force --syncwithtrees) after any additions are seemingly removed, but no dice...

Any idea how I can "reset" everything back to defaults? Can one use tlmgr maybe? I'm on Ubuntu with Texlive 2011..


EDIT: solved my problem, my notes are below - but I think it's good to know if there's a "factory reset" for these kinds of things...

It turns out I forgot a updmap --disable adobe.map, now those warnings I gone ... I just went through the log file, and saw that it has:

pdfTeX warning: pdflatex (file /home/USER/.texlive2011/texmf-var/fonts
/map/pdftex/updmap/pdftex.map): invalid entry for `@c': both ps_name and font file missing

pdfTeX warning: pdflatex (file /home/USER/.texlive2011/texmf-var/fonts
/map/pdftex/updmap/pdftex.map): ambiguous entry for `@c': font file present but
 not included, will be treated as font file not present

... and then in the mentioned pdftex.map, I could see stuff like @c " Adobe Type Basics " A 902 - which should apparently be comments, but seemingly aren't treated as such.

share|improve this question
3  
On miktex I would run updmap --verbose >updmap.log and updmap --verbose --admin>updmap2.log (--admin is the miktex equivalent of updmap-sys). And then I would check in the log-files which .cfg are used and which map-files are written and sort things out in an editor. –  Ulrike Fischer Apr 6 '12 at 17:47
    
Many thanks for the tip, @UlrikeFischer - cheers! –  sdaau Apr 6 '12 at 18:15

1 Answer 1

up vote 4 down vote accepted

On miktex I would run updmap --verbose >updmap.log and updmap --verbose --admin>updmap2.log (--admin is the miktex equivalent of updmap-sys). And then I would check in the log-files which .cfg are used and which map-files are written and sort things out in an editor.

share|improve this answer
    
Thanks for that, @UlrikeFischer - cheers! –  sdaau May 11 '12 at 6:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.