Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

In a text, I get an overfull hbox. To avoid this, I define an optional hyphenation point:

bla bla bla un\-known bla bla bla

pdflatex indeed hyphenates the word at that point. But when I declare the optional hyphenation point in the preamble like this

\hyphenation{un-known}

then pdflatex will NOT hyphenate there. The reason seems to be that LaTeX still thinks that the typeset text does not look good enough with the line break after 'un-'. But then why is the behavior different for the inline optional hyphenation to the optional hyphenation declared in the preamble?

share|improve this question
    
Are you using multiple languages with babel? –  egreg Apr 7 '12 at 15:45
    
If you can process your document with LuaTeX: include the package lua-visual-debug and you'll see the possible hyphenation points. –  topskip Apr 7 '12 at 16:07
add comment

1 Answer

up vote 3 down vote accepted

Try adding \showthe\lefthyphenmin so TeX stops and shows the value of this parameter. If it is set more than 2 then automatic hyphenation will never break after 2 letters. The default (for English) is 2, but some language setups change this.

share|improve this answer
    
No babel package used; but \showthe\lefthyphemin did the trick. It was set to 3. After setting it to 2 (simply use \lefthyphenmin=2), my optional hyphenation work as expected. Thanks for the hint. –  Klaus Apr 9 '12 at 12:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.