Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I used tikz externalize successfully for a time now. But since my pc crashed once the externalized pictures are instantly deleted. Reading the manual I found out, that they are "optimized away" because of the jobname differing of the documents (?) jobname. I did not change anything here. How can I fix that?

Here's the log of the main tex-file:

http://pastebin.com/zW60UZgH

share|improve this question

closed as not a real question by Marco Daniel, Torbjørn T., Joseph Wright May 6 '12 at 8:54

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
The log pretty much says it all, you have optimize=\false where it should have been optimize=false. If they were already externalised then this is also why it worked before, it found the image and never came to this code. –  zeroth Apr 7 '12 at 20:23
    
Sorry, I posted the wrong log. Now I changed it to the log of the main tex-file without using the optimizer=false tag. Firstly because I don't want to use it and it didn't work either. And externalizing worked well: to update a specific picture I removed it or used "tikzexternalizedisable". –  severin Apr 7 '12 at 21:06
    
It is not clear from the log where the error lies, however, it clearly states that the externalised objects are errorneous. Please supply: bilder/ext/diplom-figure3.log or any of the other externalised images, they contain the error. –  zeroth Apr 7 '12 at 21:14
    
Just guessing but did you register/ sync your dropbox folder recently after the crash? Looks like a system problem instead of LaTeX related... –  percusse Apr 7 '12 at 21:19
1  
After investigating I tracked down the problem to the following code: \begin{enumerate} \item "`asdf"' \end{enumerate} Seems like this interferes with shell-escape tikz-externalize uses. (Not allowed to answer my own question, although this is the solution. So someone could answer this :-)) –  severin Apr 7 '12 at 22:04

Browse other questions tagged or ask your own question.