Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to be able to use Mathematica fonts with LaTeX. I find two sets of instructions for this:

  1. Robert's post there

  2. Kuska's instructions in mysymdoc.pdf, a file in the Mathematica 8 folder SystemFiles/IncludeFiles/TeX/texmf/doc.

Method (1) explicitly assumes one is using linux, although robert indicates the method should work for OS X.

Method (2) uses files that are distributed with Mathematica for OS X, but Kuska refers only to MikTeX on Windows and teTeX on Unix.

Which works with TeXLive 2011 under OS X?

Also, method (1) says to edit the two .mapfiles so as to change .pfb to .pfa (presumably because the Wolfram-supplied Type 1 font files have extension .pfa.

Why edit the .map files like that instead of changing the extensions of the font files themselves to .pfb?

share|improve this question

migrated from mathematica.stackexchange.com Apr 12 '12 at 20:55

This question came from our site for users of Mathematica.

    
Method (1) is not good for TeX Live 2011. –  egreg Apr 12 '12 at 21:30
    
What about considering the mathematica package which provides support for virtual fonts? –  Werner Apr 13 '12 at 5:57
    
I thought robert said his files included the mathematica package, by Kuska, that you cite. And Kuska's package is, I believe, the same thing that's supplied with Mathematica itself, in the SystemFiles/IncludeFiles/TeX folder. –  murray Apr 13 '12 at 14:58

1 Answer 1

The instructions you mention are rather outdated.

  1. Modify wolfram.map to have .pfa instead of .pfb (to reflect the format of the font files) and remove all from Janson Text onwards, as those fonts are not provided.

  2. Copy wolfram.map to

    /usr/local/texlive/texmf-local/fonts/map/dvips/wolfram/wolfram.map
    
  3. Copy all subfolders from texmf/fonts (afm/wolfram …) to the corresponding folders in /usr/local/texlive/texmf-local/fonts.

  4. Copy the directory texmf/tex/latex/wolfram to /usr/local/texlive/texmf-local/tex/latex/wolfram

  5. Copy texmf/doc/wolfram to /usr/local/texlive/texmf-local/doc/latex/wolfram

  6. Run mktexlsr so that TeX Live will know about these files

  7. Run updmap-sys --enable-map=wolfram.map

  8. Enjoy

All steps from 2 to 7 should be done as Administrator (prefix the commands with sudo, typing the Administrator's password when requested)

Note that the 7z archive linked to in the blog article seems to be corrupt, while the .zip file is good.

share|improve this answer
    
The .zip file contents, robert says, is a subset of what's in the 7z file. In any case, I was able to unarchive the 7z file without any error message. –  murray Apr 13 '12 at 0:19
    
I keep all personal additions, including fonts inside ~/Library/texmf. I'm the only user, with an admin account. Should that not work? Is it essential, instead, to put wolfram.map (for my setup) in ~/Library/texmf/fonts/map/dvips/wolfram/? E.g., I copied wolfram.map to ~/Library/texmf/fonts/dvips/config. And I added the entry Map wolfram.map #localtexmf/dvips/config/wolfram.map to file ~/Library/texmf/web2c/updmap.cfg before running mktexlsr and updmap-sys. –  murray Apr 13 '12 at 0:25
    
@murray What's most important is not using updmap that may create problems in using fonts when they are updated via tlmgr. –  egreg Apr 13 '12 at 9:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.